git: adad7dde3200 - stable/13 - bhyve/snapshot: rename checkpoint_opcodes to be more generic

From: John Baldwin <jhb_at_FreeBSD.org>
Date: Thu, 26 Jan 2023 18:54:17 UTC
The branch stable/13 has been updated by jhb:

URL: https://cgit.FreeBSD.org/src/commit/?id=adad7dde3200bc1c6c58f1a6c835907192a84892

commit adad7dde3200bc1c6c58f1a6c835907192a84892
Author:     Robert Wing <rew@FreeBSD.org>
AuthorDate: 2021-02-27 21:03:03 +0000
Commit:     John Baldwin <jhb@FreeBSD.org>
CommitDate: 2023-01-26 18:41:45 +0000

    bhyve/snapshot: rename checkpoint_opcodes to be more generic
    
    Generalize the naming here since the domain socket that uses these codes
    might be used for purposes other than the save/restore feature.
    
    - rename checkpoint_opcodes to ipc_opcode
    
    Reviewed by:    jhb
    Differential Revision:  https://reviews.freebsd.org/D28877
    
    (cherry picked from commit b7fd9c4e5ebc69934205980d9f628ef8f21fb288)
---
 usr.sbin/bhyve/snapshot.h | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/usr.sbin/bhyve/snapshot.h b/usr.sbin/bhyve/snapshot.h
index caa7256ffbfa..62b2083b9830 100644
--- a/usr.sbin/bhyve/snapshot.h
+++ b/usr.sbin/bhyve/snapshot.h
@@ -60,9 +60,9 @@ struct restore_state {
 	ucl_object_t *meta_root_obj;
 };
 
-enum checkpoint_opcodes {
-	START_CHECKPOINT = 0,
-	START_SUSPEND = 1,
+enum ipc_opcode {
+	START_CHECKPOINT,
+	START_SUSPEND,
 };
 
 struct checkpoint_op {