git: 6ebdd83cae10 - stable/13 - stand/efi: Better variable name

From: Warner Losh <imp_at_FreeBSD.org>
Date: Tue, 24 Jan 2023 22:14:19 UTC
The branch stable/13 has been updated by imp:

URL: https://cgit.FreeBSD.org/src/commit/?id=6ebdd83cae10a8660e02fe132c33e93955bfa231

commit 6ebdd83cae10a8660e02fe132c33e93955bfa231
Author:     Warner Losh <imp@FreeBSD.org>
AuthorDate: 2023-01-08 19:00:51 +0000
Commit:     Warner Losh <imp@FreeBSD.org>
CommitDate: 2023-01-24 21:49:45 +0000

    stand/efi: Better variable name
    
    sanity_check_currdev returns true if it found a kernel or a sane loader
    config file. A better name for this would be 'bootable' rather than 'rv'
    which connotes in other places an errno value or similar.
    
    Sponsored by:           Netflix
    
    (cherry picked from commit 23ed2a38c200c93414de20d20f7508f621acecd1)
---
 stand/efi/loader/main.c | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/stand/efi/loader/main.c b/stand/efi/loader/main.c
index 57a9769f6024..a315fdea8edc 100644
--- a/stand/efi/loader/main.c
+++ b/stand/efi/loader/main.c
@@ -267,7 +267,7 @@ probe_zfs_currdev(uint64_t guid)
 	char *devname;
 	struct zfs_devdesc currdev;
 	char *buf = NULL;
-	bool rv;
+	bool bootable;
 
 	currdev.dd.d_dev = &zfs_dev;
 	currdev.dd.d_unit = 0;
@@ -277,8 +277,8 @@ probe_zfs_currdev(uint64_t guid)
 	devname = devformat(&currdev.dd);
 	init_zfs_boot_options(devname);
 
-	rv = sanity_check_currdev();
-	if (rv) {
+	bootable = sanity_check_currdev();
+	if (bootable) {
 		buf = malloc(VDEV_PAD_SIZE);
 		if (buf != NULL) {
 			if (zfs_get_bootonce(&currdev, OS_BOOTONCE, buf,
@@ -291,7 +291,7 @@ probe_zfs_currdev(uint64_t guid)
 			(void) zfs_attach_nvstore(&currdev);
 		}
 	}
-	return (rv);
+	return (bootable);
 }
 #endif