git: 3820d1e1a7e0 - main - amdsmu: Add clarifying comment for the *sw_drips metrics

From: Aymeric Wibo <obiwac_at_FreeBSD.org>
Date: Wed, 16 Sep 2026 18:49:07 UTC
The branch main has been updated by obiwac:

URL: https://cgit.FreeBSD.org/src/commit/?id=3820d1e1a7e08c2c464aca0bdd063b1595dc9127

commit 3820d1e1a7e08c2c464aca0bdd063b1595dc9127
Author:     Aymeric Wibo <obiwac@FreeBSD.org>
AuthorDate: 2026-09-16 18:45:37 +0000
Commit:     Aymeric Wibo <obiwac@FreeBSD.org>
CommitDate: 2026-09-16 18:48:21 +0000

    amdsmu: Add clarifying comment for the *sw_drips metrics
    
    Sponsored by:   The FreeBSD Foundation
---
 sys/dev/amdsmu/amdsmu_reg.h | 7 +++++++
 1 file changed, 7 insertions(+)

diff --git a/sys/dev/amdsmu/amdsmu_reg.h b/sys/dev/amdsmu/amdsmu_reg.h
index c71082072b60..503472215a8f 100644
--- a/sys/dev/amdsmu/amdsmu_reg.h
+++ b/sys/dev/amdsmu/amdsmu_reg.h
@@ -74,6 +74,13 @@ struct amdsmu_metrics {
 	uint64_t total_time_resuming;
 	uint64_t time_last_in_s0i3;
 	uint64_t total_time_in_s0i3;
+	/*
+	 * "sw_drips" here is a bit of a misnomer.  The naming comes from the
+	 * Linux driver AMD wrote, but is really a Windows concept.  In
+	 * practice, this measures how much time the system spent in "S0i0"
+	 * (i.e. completely awake) between the calls to amdsmu_suspend() and
+	 * amdsmu_resume().
+	 */
 	uint64_t time_last_in_sw_drips;
 	uint64_t total_time_in_sw_drips;
 	/*