git: fae39d8da9d5 - main - dwc: fix DEBUG macro name

From: Mitchell Horne <mhorne_at_FreeBSD.org>
Date: Tue, 27 Feb 2024 22:10:38 UTC
The branch main has been updated by mhorne:

URL: https://cgit.FreeBSD.org/src/commit/?id=fae39d8da9d5ddf4239fc2143522340c941f6612

commit fae39d8da9d5ddf4239fc2143522340c941f6612
Author:     Mitchell Horne <mhorne@FreeBSD.org>
AuthorDate: 2024-02-27 21:59:24 +0000
Commit:     Mitchell Horne <mhorne@FreeBSD.org>
CommitDate: 2024-02-27 22:10:14 +0000

    dwc: fix DEBUG macro name
    
    It conflicts with the general "DEBUG" macro defined as an option in LINT
    builds. Since this is actually unused, just rename it to GMAC_DEBUG.
    
    Reviewed by:    manu
    MFC after:      3 days
    Sponsored by:   The FreeBSD Foundation
    Differential Revision:  https://reviews.freebsd.org/D44102
---
 sys/dev/dwc/dwc1000_reg.h | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/sys/dev/dwc/dwc1000_reg.h b/sys/dev/dwc/dwc1000_reg.h
index f581bf135cd8..5b67da2447ac 100644
--- a/sys/dev/dwc/dwc1000_reg.h
+++ b/sys/dev/dwc/dwc1000_reg.h
@@ -70,7 +70,7 @@
 #define	 FLOW_CONTROL_TX	(1 << 1)	/* TX Flow control enable */
 #define	GMAC_VLAN_TAG		0x1C
 #define	VERSION			0x20
-#define	DEBUG			0x24
+#define	GMAC_DEBUG		0x24
 #define	LPI_CONTROL_STATUS	0x30
 #define	LPI_TIMERS_CONTROL	0x34
 #define	INTERRUPT_STATUS	0x38