git: 4f9fe53af15a - main - mail/p5-Sisimai: Update to 5.2.0

From: Po-Chuan Hsieh <sunpoet_at_FreeBSD.org>
Date: Fri, 14 Mar 2025 10:00:52 UTC
The branch main has been updated by sunpoet:

URL: https://cgit.FreeBSD.org/ports/commit/?id=4f9fe53af15ac0be3c04ff7a9257cb8ca3d9a494

commit 4f9fe53af15ac0be3c04ff7a9257cb8ca3d9a494
Author:     Po-Chuan Hsieh <sunpoet@FreeBSD.org>
AuthorDate: 2025-03-14 09:44:17 +0000
Commit:     Po-Chuan Hsieh <sunpoet@FreeBSD.org>
CommitDate: 2025-03-14 09:54:52 +0000

    mail/p5-Sisimai: Update to 5.2.0
    
    Changes:        https://metacpan.org/dist/Sisimai/changes
---
 mail/p5-Sisimai/Makefile  |  2 +-
 mail/p5-Sisimai/distinfo  |  6 ++--
 mail/p5-Sisimai/pkg-plist | 72 +++++++++++++++++------------------------------
 3 files changed, 30 insertions(+), 50 deletions(-)

diff --git a/mail/p5-Sisimai/Makefile b/mail/p5-Sisimai/Makefile
index 8c09b00191f9..7bf9bc5bccb6 100644
--- a/mail/p5-Sisimai/Makefile
+++ b/mail/p5-Sisimai/Makefile
@@ -1,5 +1,5 @@
 PORTNAME=	Sisimai
-PORTVERSION=	5.1.0
+PORTVERSION=	5.2.0
 DISTVERSIONPREFIX=	v
 CATEGORIES=	mail perl5
 MASTER_SITES=	CPAN
diff --git a/mail/p5-Sisimai/distinfo b/mail/p5-Sisimai/distinfo
index b9bb8c084f37..ce874c2f1e84 100644
--- a/mail/p5-Sisimai/distinfo
+++ b/mail/p5-Sisimai/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1720023772
-SHA256 (Sisimai-v5.1.0.tar.gz) = f113733d03628463ac034b81348f4c961fe36817a0eaebdbadb4246d55df5604
-SIZE (Sisimai-v5.1.0.tar.gz) = 1032890
+TIMESTAMP = 1740836368
+SHA256 (Sisimai-v5.2.0.tar.gz) = 1a944607eb4aac5811ead5d16401ef1ac1f28ac74e1e4910b0cc077f71b31b34
+SIZE (Sisimai-v5.2.0.tar.gz) = 1093212
diff --git a/mail/p5-Sisimai/pkg-plist b/mail/p5-Sisimai/pkg-plist
index 9536f1b6bbe1..aad8abd104a4 100644
--- a/mail/p5-Sisimai/pkg-plist
+++ b/mail/p5-Sisimai/pkg-plist
@@ -5,15 +5,11 @@
 %%SITE_PERL%%/Sisimai/Fact.pm
 %%SITE_PERL%%/Sisimai/Fact/JSON.pm
 %%SITE_PERL%%/Sisimai/Fact/YAML.pm
+%%SITE_PERL%%/Sisimai/LDA.pm
 %%SITE_PERL%%/Sisimai/Lhost.pm
 %%SITE_PERL%%/Sisimai/Lhost/Activehunter.pm
-%%SITE_PERL%%/Sisimai/Lhost/Amavis.pm
 %%SITE_PERL%%/Sisimai/Lhost/AmazonSES.pm
-%%SITE_PERL%%/Sisimai/Lhost/AmazonWorkMail.pm
-%%SITE_PERL%%/Sisimai/Lhost/Aol.pm
 %%SITE_PERL%%/Sisimai/Lhost/ApacheJames.pm
-%%SITE_PERL%%/Sisimai/Lhost/Barracuda.pm
-%%SITE_PERL%%/Sisimai/Lhost/Bigfoot.pm
 %%SITE_PERL%%/Sisimai/Lhost/Biglobe.pm
 %%SITE_PERL%%/Sisimai/Lhost/Courier.pm
 %%SITE_PERL%%/Sisimai/Lhost/Domino.pm
@@ -24,45 +20,29 @@
 %%SITE_PERL%%/Sisimai/Lhost/Exchange2007.pm
 %%SITE_PERL%%/Sisimai/Lhost/Exim.pm
 %%SITE_PERL%%/Sisimai/Lhost/FML.pm
-%%SITE_PERL%%/Sisimai/Lhost/Facebook.pm
 %%SITE_PERL%%/Sisimai/Lhost/GMX.pm
-%%SITE_PERL%%/Sisimai/Lhost/GSuite.pm
 %%SITE_PERL%%/Sisimai/Lhost/Gmail.pm
 %%SITE_PERL%%/Sisimai/Lhost/GoogleGroups.pm
+%%SITE_PERL%%/Sisimai/Lhost/GoogleWorkspace.pm
 %%SITE_PERL%%/Sisimai/Lhost/IMailServer.pm
 %%SITE_PERL%%/Sisimai/Lhost/InterScanMSS.pm
 %%SITE_PERL%%/Sisimai/Lhost/KDDI.pm
-%%SITE_PERL%%/Sisimai/Lhost/MXLogic.pm
 %%SITE_PERL%%/Sisimai/Lhost/MailFoundry.pm
 %%SITE_PERL%%/Sisimai/Lhost/MailMarshalSMTP.pm
-%%SITE_PERL%%/Sisimai/Lhost/MailRu.pm
-%%SITE_PERL%%/Sisimai/Lhost/McAfee.pm
-%%SITE_PERL%%/Sisimai/Lhost/MessageLabs.pm
 %%SITE_PERL%%/Sisimai/Lhost/MessagingServer.pm
 %%SITE_PERL%%/Sisimai/Lhost/Notes.pm
-%%SITE_PERL%%/Sisimai/Lhost/Office365.pm
 %%SITE_PERL%%/Sisimai/Lhost/OpenSMTPD.pm
-%%SITE_PERL%%/Sisimai/Lhost/Outlook.pm
 %%SITE_PERL%%/Sisimai/Lhost/Postfix.pm
-%%SITE_PERL%%/Sisimai/Lhost/PowerMTA.pm
-%%SITE_PERL%%/Sisimai/Lhost/ReceivingSES.pm
-%%SITE_PERL%%/Sisimai/Lhost/SendGrid.pm
 %%SITE_PERL%%/Sisimai/Lhost/Sendmail.pm
-%%SITE_PERL%%/Sisimai/Lhost/SurfControl.pm
 %%SITE_PERL%%/Sisimai/Lhost/V5sendmail.pm
 %%SITE_PERL%%/Sisimai/Lhost/Verizon.pm
 %%SITE_PERL%%/Sisimai/Lhost/X1.pm
 %%SITE_PERL%%/Sisimai/Lhost/X2.pm
 %%SITE_PERL%%/Sisimai/Lhost/X3.pm
-%%SITE_PERL%%/Sisimai/Lhost/X4.pm
-%%SITE_PERL%%/Sisimai/Lhost/X5.pm
 %%SITE_PERL%%/Sisimai/Lhost/X6.pm
-%%SITE_PERL%%/Sisimai/Lhost/Yahoo.pm
-%%SITE_PERL%%/Sisimai/Lhost/Yandex.pm
 %%SITE_PERL%%/Sisimai/Lhost/Zoho.pm
 %%SITE_PERL%%/Sisimai/Lhost/mFILTER.pm
 %%SITE_PERL%%/Sisimai/Lhost/qmail.pm
-%%SITE_PERL%%/Sisimai/MDA.pm
 %%SITE_PERL%%/Sisimai/Mail.pm
 %%SITE_PERL%%/Sisimai/Mail/Maildir.pm
 %%SITE_PERL%%/Sisimai/Mail/Mbox.pm
@@ -70,12 +50,15 @@
 %%SITE_PERL%%/Sisimai/Mail/STDIN.pm
 %%SITE_PERL%%/Sisimai/Message.pm
 %%SITE_PERL%%/Sisimai/Order.pm
+%%SITE_PERL%%/Sisimai/RFC1123.pm
 %%SITE_PERL%%/Sisimai/RFC1894.pm
 %%SITE_PERL%%/Sisimai/RFC2045.pm
 %%SITE_PERL%%/Sisimai/RFC3464.pm
+%%SITE_PERL%%/Sisimai/RFC3464/ThirdParty.pm
 %%SITE_PERL%%/Sisimai/RFC3834.pm
 %%SITE_PERL%%/Sisimai/RFC5322.pm
 %%SITE_PERL%%/Sisimai/RFC5965.pm
+%%SITE_PERL%%/Sisimai/RFC791.pm
 %%SITE_PERL%%/Sisimai/Reason.pm
 %%SITE_PERL%%/Sisimai/Reason/AuthFailure.pm
 %%SITE_PERL%%/Sisimai/Reason/BadReputation.pm
@@ -84,6 +67,7 @@
 %%SITE_PERL%%/Sisimai/Reason/Delivered.pm
 %%SITE_PERL%%/Sisimai/Reason/ExceedLimit.pm
 %%SITE_PERL%%/Sisimai/Reason/Expired.pm
+%%SITE_PERL%%/Sisimai/Reason/FailedSTARTTLS.pm
 %%SITE_PERL%%/Sisimai/Reason/Feedback.pm
 %%SITE_PERL%%/Sisimai/Reason/Filtered.pm
 %%SITE_PERL%%/Sisimai/Reason/HasMoved.pm
@@ -102,6 +86,7 @@
 %%SITE_PERL%%/Sisimai/Reason/SecurityError.pm
 %%SITE_PERL%%/Sisimai/Reason/SpamDetected.pm
 %%SITE_PERL%%/Sisimai/Reason/Speeding.pm
+%%SITE_PERL%%/Sisimai/Reason/Suppressed.pm
 %%SITE_PERL%%/Sisimai/Reason/Suspend.pm
 %%SITE_PERL%%/Sisimai/Reason/SyntaxError.pm
 %%SITE_PERL%%/Sisimai/Reason/SystemError.pm
@@ -112,22 +97,27 @@
 %%SITE_PERL%%/Sisimai/Reason/Vacation.pm
 %%SITE_PERL%%/Sisimai/Reason/VirusDetected.pm
 %%SITE_PERL%%/Sisimai/Rhost.pm
+%%SITE_PERL%%/Sisimai/Rhost/Aol.pm
 %%SITE_PERL%%/Sisimai/Rhost/Apple.pm
 %%SITE_PERL%%/Sisimai/Rhost/Cox.pm
+%%SITE_PERL%%/Sisimai/Rhost/Facebook.pm
 %%SITE_PERL%%/Sisimai/Rhost/FrancePTT.pm
+%%SITE_PERL%%/Sisimai/Rhost/GSuite.pm
 %%SITE_PERL%%/Sisimai/Rhost/GoDaddy.pm
 %%SITE_PERL%%/Sisimai/Rhost/Google.pm
 %%SITE_PERL%%/Sisimai/Rhost/IUA.pm
 %%SITE_PERL%%/Sisimai/Rhost/KDDI.pm
+%%SITE_PERL%%/Sisimai/Rhost/MessageLabs.pm
 %%SITE_PERL%%/Sisimai/Rhost/Microsoft.pm
 %%SITE_PERL%%/Sisimai/Rhost/Mimecast.pm
 %%SITE_PERL%%/Sisimai/Rhost/NTTDOCOMO.pm
+%%SITE_PERL%%/Sisimai/Rhost/Outlook.pm
 %%SITE_PERL%%/Sisimai/Rhost/Spectrum.pm
 %%SITE_PERL%%/Sisimai/Rhost/Tencent.pm
 %%SITE_PERL%%/Sisimai/Rhost/YahooInc.pm
 %%SITE_PERL%%/Sisimai/SMTP.pm
 %%SITE_PERL%%/Sisimai/SMTP/Command.pm
-%%SITE_PERL%%/Sisimai/SMTP/Error.pm
+%%SITE_PERL%%/Sisimai/SMTP/Failure.pm
 %%SITE_PERL%%/Sisimai/SMTP/Reply.pm
 %%SITE_PERL%%/Sisimai/SMTP/Status.pm
 %%SITE_PERL%%/Sisimai/SMTP/Transcript.pm
@@ -140,15 +130,11 @@
 %%PERL5_MAN3%%/Sisimai::Fact.3.gz
 %%PERL5_MAN3%%/Sisimai::Fact::JSON.3.gz
 %%PERL5_MAN3%%/Sisimai::Fact::YAML.3.gz
+%%PERL5_MAN3%%/Sisimai::LDA.3.gz
 %%PERL5_MAN3%%/Sisimai::Lhost.3.gz
 %%PERL5_MAN3%%/Sisimai::Lhost::Activehunter.3.gz
-%%PERL5_MAN3%%/Sisimai::Lhost::Amavis.3.gz
 %%PERL5_MAN3%%/Sisimai::Lhost::AmazonSES.3.gz
-%%PERL5_MAN3%%/Sisimai::Lhost::AmazonWorkMail.3.gz
-%%PERL5_MAN3%%/Sisimai::Lhost::Aol.3.gz
 %%PERL5_MAN3%%/Sisimai::Lhost::ApacheJames.3.gz
-%%PERL5_MAN3%%/Sisimai::Lhost::Barracuda.3.gz
-%%PERL5_MAN3%%/Sisimai::Lhost::Bigfoot.3.gz
 %%PERL5_MAN3%%/Sisimai::Lhost::Biglobe.3.gz
 %%PERL5_MAN3%%/Sisimai::Lhost::Courier.3.gz
 %%PERL5_MAN3%%/Sisimai::Lhost::Domino.3.gz
@@ -159,45 +145,29 @@
 %%PERL5_MAN3%%/Sisimai::Lhost::Exchange2007.3.gz
 %%PERL5_MAN3%%/Sisimai::Lhost::Exim.3.gz
 %%PERL5_MAN3%%/Sisimai::Lhost::FML.3.gz
-%%PERL5_MAN3%%/Sisimai::Lhost::Facebook.3.gz
 %%PERL5_MAN3%%/Sisimai::Lhost::GMX.3.gz
-%%PERL5_MAN3%%/Sisimai::Lhost::GSuite.3.gz
 %%PERL5_MAN3%%/Sisimai::Lhost::Gmail.3.gz
 %%PERL5_MAN3%%/Sisimai::Lhost::GoogleGroups.3.gz
+%%PERL5_MAN3%%/Sisimai::Lhost::GoogleWorkspace.3.gz
 %%PERL5_MAN3%%/Sisimai::Lhost::IMailServer.3.gz
 %%PERL5_MAN3%%/Sisimai::Lhost::InterScanMSS.3.gz
 %%PERL5_MAN3%%/Sisimai::Lhost::KDDI.3.gz
-%%PERL5_MAN3%%/Sisimai::Lhost::MXLogic.3.gz
 %%PERL5_MAN3%%/Sisimai::Lhost::MailFoundry.3.gz
 %%PERL5_MAN3%%/Sisimai::Lhost::MailMarshalSMTP.3.gz
-%%PERL5_MAN3%%/Sisimai::Lhost::MailRu.3.gz
-%%PERL5_MAN3%%/Sisimai::Lhost::McAfee.3.gz
-%%PERL5_MAN3%%/Sisimai::Lhost::MessageLabs.3.gz
 %%PERL5_MAN3%%/Sisimai::Lhost::MessagingServer.3.gz
 %%PERL5_MAN3%%/Sisimai::Lhost::Notes.3.gz
-%%PERL5_MAN3%%/Sisimai::Lhost::Office365.3.gz
 %%PERL5_MAN3%%/Sisimai::Lhost::OpenSMTPD.3.gz
-%%PERL5_MAN3%%/Sisimai::Lhost::Outlook.3.gz
 %%PERL5_MAN3%%/Sisimai::Lhost::Postfix.3.gz
-%%PERL5_MAN3%%/Sisimai::Lhost::PowerMTA.3.gz
-%%PERL5_MAN3%%/Sisimai::Lhost::ReceivingSES.3.gz
-%%PERL5_MAN3%%/Sisimai::Lhost::SendGrid.3.gz
 %%PERL5_MAN3%%/Sisimai::Lhost::Sendmail.3.gz
-%%PERL5_MAN3%%/Sisimai::Lhost::SurfControl.3.gz
 %%PERL5_MAN3%%/Sisimai::Lhost::V5sendmail.3.gz
 %%PERL5_MAN3%%/Sisimai::Lhost::Verizon.3.gz
 %%PERL5_MAN3%%/Sisimai::Lhost::X1.3.gz
 %%PERL5_MAN3%%/Sisimai::Lhost::X2.3.gz
 %%PERL5_MAN3%%/Sisimai::Lhost::X3.3.gz
-%%PERL5_MAN3%%/Sisimai::Lhost::X4.3.gz
-%%PERL5_MAN3%%/Sisimai::Lhost::X5.3.gz
 %%PERL5_MAN3%%/Sisimai::Lhost::X6.3.gz
-%%PERL5_MAN3%%/Sisimai::Lhost::Yahoo.3.gz
-%%PERL5_MAN3%%/Sisimai::Lhost::Yandex.3.gz
 %%PERL5_MAN3%%/Sisimai::Lhost::Zoho.3.gz
 %%PERL5_MAN3%%/Sisimai::Lhost::mFILTER.3.gz
 %%PERL5_MAN3%%/Sisimai::Lhost::qmail.3.gz
-%%PERL5_MAN3%%/Sisimai::MDA.3.gz
 %%PERL5_MAN3%%/Sisimai::Mail.3.gz
 %%PERL5_MAN3%%/Sisimai::Mail::Maildir.3.gz
 %%PERL5_MAN3%%/Sisimai::Mail::Mbox.3.gz
@@ -205,12 +175,15 @@
 %%PERL5_MAN3%%/Sisimai::Mail::STDIN.3.gz
 %%PERL5_MAN3%%/Sisimai::Message.3.gz
 %%PERL5_MAN3%%/Sisimai::Order.3.gz
+%%PERL5_MAN3%%/Sisimai::RFC1123.3.gz
 %%PERL5_MAN3%%/Sisimai::RFC1894.3.gz
 %%PERL5_MAN3%%/Sisimai::RFC2045.3.gz
 %%PERL5_MAN3%%/Sisimai::RFC3464.3.gz
+%%PERL5_MAN3%%/Sisimai::RFC3464::ThirdParty.3.gz
 %%PERL5_MAN3%%/Sisimai::RFC3834.3.gz
 %%PERL5_MAN3%%/Sisimai::RFC5322.3.gz
 %%PERL5_MAN3%%/Sisimai::RFC5965.3.gz
+%%PERL5_MAN3%%/Sisimai::RFC791.3.gz
 %%PERL5_MAN3%%/Sisimai::Reason.3.gz
 %%PERL5_MAN3%%/Sisimai::Reason::AuthFailure.3.gz
 %%PERL5_MAN3%%/Sisimai::Reason::BadReputation.3.gz
@@ -219,6 +192,7 @@
 %%PERL5_MAN3%%/Sisimai::Reason::Delivered.3.gz
 %%PERL5_MAN3%%/Sisimai::Reason::ExceedLimit.3.gz
 %%PERL5_MAN3%%/Sisimai::Reason::Expired.3.gz
+%%PERL5_MAN3%%/Sisimai::Reason::FailedSTARTTLS.3.gz
 %%PERL5_MAN3%%/Sisimai::Reason::Feedback.3.gz
 %%PERL5_MAN3%%/Sisimai::Reason::Filtered.3.gz
 %%PERL5_MAN3%%/Sisimai::Reason::HasMoved.3.gz
@@ -237,6 +211,7 @@
 %%PERL5_MAN3%%/Sisimai::Reason::SecurityError.3.gz
 %%PERL5_MAN3%%/Sisimai::Reason::SpamDetected.3.gz
 %%PERL5_MAN3%%/Sisimai::Reason::Speeding.3.gz
+%%PERL5_MAN3%%/Sisimai::Reason::Suppressed.3.gz
 %%PERL5_MAN3%%/Sisimai::Reason::Suspend.3.gz
 %%PERL5_MAN3%%/Sisimai::Reason::SyntaxError.3.gz
 %%PERL5_MAN3%%/Sisimai::Reason::SystemError.3.gz
@@ -247,22 +222,27 @@
 %%PERL5_MAN3%%/Sisimai::Reason::Vacation.3.gz
 %%PERL5_MAN3%%/Sisimai::Reason::VirusDetected.3.gz
 %%PERL5_MAN3%%/Sisimai::Rhost.3.gz
+%%PERL5_MAN3%%/Sisimai::Rhost::Aol.3.gz
 %%PERL5_MAN3%%/Sisimai::Rhost::Apple.3.gz
 %%PERL5_MAN3%%/Sisimai::Rhost::Cox.3.gz
+%%PERL5_MAN3%%/Sisimai::Rhost::Facebook.3.gz
 %%PERL5_MAN3%%/Sisimai::Rhost::FrancePTT.3.gz
+%%PERL5_MAN3%%/Sisimai::Rhost::GSuite.3.gz
 %%PERL5_MAN3%%/Sisimai::Rhost::GoDaddy.3.gz
 %%PERL5_MAN3%%/Sisimai::Rhost::Google.3.gz
 %%PERL5_MAN3%%/Sisimai::Rhost::IUA.3.gz
 %%PERL5_MAN3%%/Sisimai::Rhost::KDDI.3.gz
+%%PERL5_MAN3%%/Sisimai::Rhost::MessageLabs.3.gz
 %%PERL5_MAN3%%/Sisimai::Rhost::Microsoft.3.gz
 %%PERL5_MAN3%%/Sisimai::Rhost::Mimecast.3.gz
 %%PERL5_MAN3%%/Sisimai::Rhost::NTTDOCOMO.3.gz
+%%PERL5_MAN3%%/Sisimai::Rhost::Outlook.3.gz
 %%PERL5_MAN3%%/Sisimai::Rhost::Spectrum.3.gz
 %%PERL5_MAN3%%/Sisimai::Rhost::Tencent.3.gz
 %%PERL5_MAN3%%/Sisimai::Rhost::YahooInc.3.gz
 %%PERL5_MAN3%%/Sisimai::SMTP.3.gz
 %%PERL5_MAN3%%/Sisimai::SMTP::Command.3.gz
-%%PERL5_MAN3%%/Sisimai::SMTP::Error.3.gz
+%%PERL5_MAN3%%/Sisimai::SMTP::Failure.3.gz
 %%PERL5_MAN3%%/Sisimai::SMTP::Reply.3.gz
 %%PERL5_MAN3%%/Sisimai::SMTP::Status.3.gz
 %%PERL5_MAN3%%/Sisimai::SMTP::Transcript.3.gz