Re: cvs commit: ports/Mk bsd.ruby.mk ports/lang/ruby18 Makefile distinfo pkg-plist ports/lang/ruby18/files patch-cgi.rb ports/x11-toolkits/ruby-tk pkg-plist

From: Jeremy Messenger <mezz7_at_cox.net>
Date: Thu, 23 Dec 2004 15:18:05 -0600
On Fri, 24 Dec 2004 06:02:44 +0900, Akinori MUSHA <knu_at_iDaemons.org> wrote:

> At Thu, 23 Dec 2004 14:41:45 -0600,
> Jeremy Messenger wrote:
>> On Thu, 23 Dec 2004 20:30:10 +0000 (UTC), Akinori MUSHA
>> <knu_at_FreeBSD.org>  wrote:
>>
>> > knu         2004-12-23 20:30:09 UTC
>> >
>> >   FreeBSD ports repository
>> >
>> >   Modified files:
>> >     Mk                   bsd.ruby.mk
>> >     lang/ruby18          Makefile distinfo pkg-plist
>> >     x11-toolkits/ruby-tk pkg-plist
>> >   Removed files:
>> >     lang/ruby18/files    patch-cgi.rb
>> >   Log:
>> >   Update lang/ruby18 to 1.8.2-preview4.
>> >  * Please upgrade sysutils/portupgrade prior to this one, or pkgdb(1)
>> >     may coredump with a double free() problem from a misuse of the DL
>> >     module.  In that case, reinstall sysutils/portupgrade manually.
>>
>> I didn't check those yet, but have you add '-pthread' as default yet?
>> ruby-gtk2/ruby-gnome2 are broke by default in FreeBSD 5.x and 6.x,
>> because  of ruby doesn't use -pthread. I have emailed to you few times
>> and you  never have reply back.
>>
>> Also, I think we should get rid of _r stuff if it possible. The _r is
>> creating problems, so how about enable it by default?
>
> Sorry, but I have't got to be sure that ruby with -pthread enabled
> works flawlessly.  Do you?  I'll do some more tests this weekend on my
> FreeBSD 5.x box.  If it goes fine, I'll happily enable it by default.

I can't test it right now.. I can test it tomorrow when I downgrade GNOME  
2.9.x to 2.8.x by via package.

> On the other hand, I still believe ruby with -pthread enabled does
> coredump on FreeBSD 4.x when combined with a certain kind of external
> libraries, so we can only enable it on FreeBSD >=5.x.  What is your
> suggestion with ruby_r vs. FreeBSD 4.x?

So, you mean the 'RUBY_CONFIGURE_ARGS+=	--with-libc_r=yes' cause the  
coredump on FreeBSD 4.x? If no, then how about use it by default and  
remove the _r voodoo, while we are there enable -pthread only on FreeBSD  
>=5.x?

I still have to admit that I don't know ruby VS FreeBSD 4.x that well.

Cheers,
Mezz


-- 
mezz7_at_cox.net  -  mezz_at_FreeBSD.org
FreeBSD GNOME Team
http://www.FreeBSD.org/gnome/  -  gnome_at_FreeBSD.org
Received on Thu Dec 23 2004 - 21:17:29 UTC