PERFORCE change 100712 for review

Robert Watson rwatson at FreeBSD.org
Thu Jul 6 10:20:22 UTC 2006


http://perforce.freebsd.org/chv.cgi?CH=100712

Change 100712 by rwatson at rwatson_zoo on 2006/07/06 10:20:03

	Simplify entry point naming for devfs.

Affected files ...

.. //depot/projects/trustedbsd/mac2/sys/sys/mac_framework.h#5 edit
.. //depot/projects/trustedbsd/mac2/sys/sys/mac_policy.h#12 edit

Differences ...

==== //depot/projects/trustedbsd/mac2/sys/sys/mac_framework.h#5 (text+ko) ====

@@ -96,8 +96,8 @@
 void	mac_bpfdesc_create_mbuf(struct bpf_d *bpf_d, struct mbuf *m);
 int	mac_bpfdesc_check_receive(struct bpf_d *bpf_d, struct ifnet *ifnet);
 
-void	mac_devfsdirent_init(struct devfs_dirent *);
-void	mac_devfsdirent_destroy(struct devfs_dirent *);
+void	mac_devfs_init(struct devfs_dirent *);
+void	mac_devfs_destroy(struct devfs_dirent *);
 void	mac_devfs_vnode_associate(struct mount *mp, struct devfs_dirent *de,
 	    struct vnode *vp);
 void	mac_devfs_create_device(struct ucred *cred, struct mount *mp,
@@ -106,7 +106,7 @@
 	    int dirnamelen, struct devfs_dirent *de);
 void	mac_devfs_create_symlink(struct ucred *cred, struct mount *mp,
 	    struct devfs_dirent *dd, struct devfs_dirent *de);
-void	mac_devfsdirent_update(struct mount *mp, struct devfs_dirent *de,
+void	mac_devfs_update(struct mount *mp, struct devfs_dirent *de,
 	    struct vnode *vp);
 
 void	mac_cred_init(struct ucred *);

==== //depot/projects/trustedbsd/mac2/sys/sys/mac_policy.h#12 (text+ko) ====

@@ -145,8 +145,8 @@
 /*
  * Object: struct devfsdirent (Devfs directory entry)
  */
-typedef void	(*mpo_devfsdirent_init_label_t)(struct label *label);
-typedef void	(*mpo_devfsdirent_destroy_label_t)(struct label *label);
+typedef void	(*mpo_devfs_init_label_t)(struct label *label);
+typedef void	(*mpo_devfs_destroy_label_t)(struct label *label);
 typedef void	(*mpo_devfs_vnode_associate_t)(struct mount *mp,
 		    struct label *fslabel, struct devfs_dirent *de,
 		    struct label *delabel, struct vnode *vp,
@@ -161,7 +161,7 @@
 		    struct mount *mp, struct devfs_dirent *dd,
 		    struct label *ddlabel, struct devfs_dirent *de,
 		    struct label *delabel);
-typedef void	(*mpo_devfsdirent_update_t)(struct mount *mp,
+typedef void	(*mpo_devfs_update_t)(struct mount *mp,
 		    struct devfs_dirent *devfs_dirent,
 		    struct label *direntlabel, struct vnode *vp,
 		    struct label *vnodelabel);
@@ -675,13 +675,13 @@
 	 * XXXRW: Naming consistency here -- perhaps should just be
 	 * mpo_devfs_*.
 	 */
-	mpo_devfsdirent_init_label_t		mpo_devfsdirent_init_label;
-	mpo_devfsdirent_destroy_label_t		mpo_devfsdirent_destroy_label;
+	mpo_devfs_init_label_t			mpo_devfs_init_label;
+	mpo_devfs_destroy_label_t		mpo_devfs_destroy_label;
 	mpo_devfs_vnode_associate_t		mpo_devfs_vnode_associate;
 	mpo_devfs_create_device_t		mpo_devfs_create_device;
 	mpo_devfs_create_directory_t		mpo_devfs_create_directory;
 	mpo_devfs_create_symlink_t		mpo_devfs_create_symlink;
-	mpo_devfsdirent_update_t		mpo_devfsdirent_update_t;
+	mpo_devfs_update_t			mpo_devfs_update_t;
 
 	/*
 	 * XXXRW: Perhaps should be mpo_ucred_*.


More information about the trustedbsd-cvs mailing list