PERFORCE change 90092 for review

Robert Watson rwatson at FreeBSD.org
Sat Jan 21 15:27:43 GMT 2006


http://perforce.freebsd.org/chv.cgi?CH=90092

Change 90092 by rwatson at rwatson_sesame on 2006/01/21 15:26:59

	Rename 'delim' to 'flagdelim' to match changes in other BSM
	related database code.

Affected files ...

.. //depot/projects/trustedbsd/openbsm/libbsm/bsm_flags.c#9 edit

Differences ...

==== //depot/projects/trustedbsd/openbsm/libbsm/bsm_flags.c#9 (text+ko) ====

@@ -34,7 +34,7 @@
 #include <stdio.h>
 #include <string.h>
 
-static const char	*delim = ",";
+static const char	*flagdelim = ",";
 
 /*
  * Convert the character representation of audit values into the au_mask_t
@@ -65,7 +65,7 @@
 	masks->am_success = 0;
 	masks->am_failure = 0;
 
-	tok = strtok_r(auditstr, delim, &last);
+	tok = strtok_r(auditstr, flagdelim, &last);
 	while (tok != NULL) {
 		/* Check for the events that should not be audited. */
 		if (tok[0] == '^') {
@@ -95,7 +95,7 @@
 		}
 
 		/* Get the next class. */
-		tok = strtok_r(NULL, delim, &last);
+		tok = strtok_r(NULL, flagdelim, &last);
 	}
 	return (0);
 }
To Unsubscribe: send mail to majordomo at trustedbsd.org
with "unsubscribe trustedbsd-cvs" in the body of the message



More information about the trustedbsd-cvs mailing list