svn commit: r347041 - stable/12/sys/fs/nfsserver

Rick Macklem rmacklem at FreeBSD.org
Fri May 3 02:44:58 UTC 2019


Author: rmacklem
Date: Fri May  3 02:44:57 2019
New Revision: 347041
URL: https://svnweb.freebsd.org/changeset/base/347041

Log:
  MFC: r346423
  Replace "vp" with NULL to make the code more readable.
  
  At the time of this nfsv4_sattr() call, "vp == NULL", so this patch doesn't
  change the semantics, but I think it makes the code more readable.
  It also makes it consistent with the nfsv4_sattr() call a few lines above
  this one. Found during code inspection.

Modified:
  stable/12/sys/fs/nfsserver/nfs_nfsdserv.c
Directory Properties:
  stable/12/   (props changed)

Modified: stable/12/sys/fs/nfsserver/nfs_nfsdserv.c
==============================================================================
--- stable/12/sys/fs/nfsserver/nfs_nfsdserv.c	Fri May  3 02:30:01 2019	(r347040)
+++ stable/12/sys/fs/nfsserver/nfs_nfsdserv.c	Fri May  3 02:44:57 2019	(r347041)
@@ -2872,7 +2872,7 @@ nfsrvd_open(struct nfsrv_descript *nd, __unused int is
 			NFSM_DISSECT(tl, u_int32_t *, NFSX_VERF);
 			cverf[0] = *tl++;
 			cverf[1] = *tl;
-			error = nfsv4_sattr(nd, vp, &nva, &attrbits, aclp, p);
+			error = nfsv4_sattr(nd, NULL, &nva, &attrbits, aclp, p);
 			if (error != 0)
 				goto nfsmout;
 			if (NFSISSET_ATTRBIT(&attrbits,


More information about the svn-src-stable mailing list