svn commit: r227701 - in head/sys: arm/xscale/ixp425 dev/ahci
dev/ata dev/gpio dev/mvs dev/ppbus dev/ppc dev/siba dev/siis
dev/usb kern sys
jhb at freebsd.org
Tue Nov 22 13:11:17 UTC 2011
On Monday, November 21, 2011 1:39:33 pm Marius Strobl wrote:
> On Mon, Nov 21, 2011 at 11:16:47AM -0500, John Baldwin wrote:
> > On Saturday, November 19, 2011 5:11:51 am Hans Petter Selasky wrote:
> > > Author: hselasky
> > > Date: Sat Nov 19 10:11:50 2011
> > > New Revision: 227701
> > > URL: http://svn.freebsd.org/changeset/base/227701
> > >
> > > Log:
> > > Move the device_delete_all_children() function from usb_util.c
> > > to kern/subr_bus.c. Simplify this function so that it no longer
> > > depends on malloc() to execute. Identify a few other places where
> > > it makes sense to use device_delete_all_children().
> > >
> > > MFC after: 1 week
> > Sorry I didn't review this earlier when you sent it to me. In general I
> > think this is a good idea, and reducing the duplicated code is great.
> Could we rename it to just device_delete_children(9)? Using both "all" and
> the plural seems redundant and doesn't match device_get_children(9) which
> also operates on all children.
That sounds like a good idea.
More information about the svn-src-head