svn commit: r188229 - in stable/7/sys: . contrib/pf dev/ath/ath_hal dev/cxgb kern

Robert Watson rwatson at FreeBSD.org
Fri Feb 6 04:27:27 PST 2009


Author: rwatson
Date: Fri Feb  6 12:27:25 2009
New Revision: 188229
URL: http://svn.freebsd.org/changeset/base/188229

Log:
  Merge r186603 from head to stabl/7:
  
    Rename mbcnt to mbcnt_delta in uipc_send() -- unlike other local
    variables named mbcnt in uipc_usrreq.c, this instance is a delta
    rather than a cache of sb_mbcnt.

Modified:
  stable/7/sys/   (props changed)
  stable/7/sys/contrib/pf/   (props changed)
  stable/7/sys/dev/ath/ath_hal/   (props changed)
  stable/7/sys/dev/cxgb/   (props changed)
  stable/7/sys/kern/uipc_usrreq.c

Modified: stable/7/sys/kern/uipc_usrreq.c
==============================================================================
--- stable/7/sys/kern/uipc_usrreq.c	Fri Feb  6 12:24:30 2009	(r188228)
+++ stable/7/sys/kern/uipc_usrreq.c	Fri Feb  6 12:27:25 2009	(r188229)
@@ -751,7 +751,7 @@ uipc_send(struct socket *so, int flags, 
 {
 	struct unpcb *unp, *unp2;
 	struct socket *so2;
-	u_int mbcnt, sbcc;
+	u_int mbcnt_delta, sbcc;
 	u_long newhiwat;
 	int error = 0;
 
@@ -881,7 +881,7 @@ uipc_send(struct socket *so, int flags, 
 				control = NULL;
 		} else
 			sbappend_locked(&so2->so_rcv, m);
-		mbcnt = so2->so_rcv.sb_mbcnt - unp2->unp_mbcnt;
+		mbcnt_delta = so2->so_rcv.sb_mbcnt - unp2->unp_mbcnt;
 		unp2->unp_mbcnt = so2->so_rcv.sb_mbcnt;
 		sbcc = so2->so_rcv.sb_cc;
 		sorwakeup_locked(so2);
@@ -890,7 +890,7 @@ uipc_send(struct socket *so, int flags, 
 		newhiwat = so->so_snd.sb_hiwat - (sbcc - unp2->unp_cc);
 		(void)chgsbsize(so->so_cred->cr_uidinfo, &so->so_snd.sb_hiwat,
 		    newhiwat, RLIM_INFINITY);
-		so->so_snd.sb_mbmax -= mbcnt;
+		so->so_snd.sb_mbmax -= mbcnt_delta;
 		SOCKBUF_UNLOCK(&so->so_snd);
 		unp2->unp_cc = sbcc;
 		UNP_PCB_UNLOCK(unp2);


More information about the svn-src-all mailing list