PERFORCE change 126469 for review

Oleksandr Tymoshenko gonzo at FreeBSD.org
Sun Sep 16 05:47:29 PDT 2007


http://perforce.freebsd.org/chv.cgi?CH=126469

Change 126469 by gonzo at gonzo_jeeves on 2007/09/16 12:47:23

	o Remove printf from tick_init_params since UART code may use
	    DELAY(9) so tick_init_params should be called before cninit.

Affected files ...

.. //depot/projects/mips2/src/sys/mips/mips/tick.c#18 edit

Differences ...

==== //depot/projects/mips2/src/sys/mips/mips/tick.c#18 (text+ko) ====

@@ -83,6 +83,10 @@
 tick_init_params(uint64_t platform_counter_freq, int double_count)
 {
 
+	/* 
+	 * XXX: Do not use printf here: uart code 8250 may use DELAY so
+	 * this function should  be called before cninit. 
+	 */
 	counter_freq = platform_counter_freq;
 
 	counts_per_hz = counter_freq / hz;
@@ -97,13 +101,13 @@
 		counts_per_usec /= 2;
 	}
 
-	printf("MIPS32 clock: %ju Hz\n", (intmax_t)counter_freq);
 	set_cputicker(tick_ticker, counter_freq, 1);
 }
 
 void tick_init(void)
 {
 
+	printf("MIPS32 clock: %ju Hz\n", (intmax_t)counter_freq);
 	if (counter_freq != 0 && !counter_is_broken) {
 		counter_timecounter.tc_frequency = counter_freq;
 		tc_init(&counter_timecounter);


More information about the p4-projects mailing list