PERFORCE change 115073 for review

Oleksandr Tymoshenko gonzo at FreeBSD.org
Mon Feb 26 17:56:34 UTC 2007


http://perforce.freebsd.org/chv.cgi?CH=115073

Change 115073 by gonzo at gonzo_jeeves on 2007/02/26 17:56:23

	o Change registers naming convention in respect to selected ABI.

Affected files ...

.. //depot/projects/mips2/src/sys/mips/include/asm.h#9 edit

Differences ...

==== //depot/projects/mips2/src/sys/mips/include/asm.h#9 (text+ko) ====

@@ -81,14 +81,29 @@
 #define a1	$5
 #define a2	$6
 #define a3	$7
-#define a4	$8	/* (T)		temporary registers	*/
-#define a5	$9
-#define a6 	$10
-#define a7	$11
-#define t0	$12
-#define t1	$13
-#define t2	$14
-#define t3	$15
+/* 
+ * There is neither n32 nor n64 ABI support on the moment, but we'll 
+ * leave these defines to our descendants.
+ */
+#if defined(__mips_n32) || defined(__mips_n64)
+#define	a4	$8
+#define	a5	$9
+#define	a6	$10
+#define	a7	$11
+#define	t0	$12	/* temp registers (not saved across subroutine calls) */
+#define	t1	$13
+#define	t2	$14
+#define	t3	$15
+#else
+#define t0	$8	/* temp registers (not saved across subroutine calls) */
+#define t1	$9
+#define t2	$10
+#define t3	$11
+#define t4	$12
+#define t5	$13
+#define t6	$14
+#define t7	$15
+#endif /* __mips_n32 || __mips_n64 */
 #define s0	$16	/* (S)		call-safe registers	*/
 #define s1	$17
 #define s2	$18


More information about the p4-projects mailing list