PERFORCE change 93603 for review

Robert Watson rwatson at FreeBSD.org
Sun Mar 19 21:31:51 UTC 2006


http://perforce.freebsd.org/chv.cgi?CH=93603

Change 93603 by rwatson at rwatson_peppercorn on 2006/03/19 21:31:14

	Rename wait_for_triggers() to wait_for_events(), as it is waiting
	for both triggers and signals to perform state transitions.

Affected files ...

.. //depot/projects/trustedbsd/openbsm/bin/auditd/auditd.c#14 edit

Differences ...

==== //depot/projects/trustedbsd/openbsm/bin/auditd/auditd.c#14 (text+ko) ====

@@ -30,7 +30,7 @@
  *
  * @APPLE_BSD_LICENSE_HEADER_END@
  *
- * $P4: //depot/projects/trustedbsd/openbsm/bin/auditd/auditd.c#13 $
+ * $P4: //depot/projects/trustedbsd/openbsm/bin/auditd/auditd.c#14 $
  */
 
 #include <sys/types.h>
@@ -596,10 +596,10 @@
 }
 
 /*
- * Read the control file for triggers and handle appropriately.
+ * Read the control file for triggers/signals and handle appropriately.
  */
 static int
-wait_for_triggers(void)
+wait_for_events(void)
 {
 	int num;
 	unsigned int trigger;
@@ -814,7 +814,7 @@
 
 	setup();
 
-	rc = wait_for_triggers();
+	rc = wait_for_events();
 	syslog(LOG_INFO, "auditd exiting.\n");
 
 	exit(rc);


More information about the p4-projects mailing list