Xorg / FreeBSD 9.0-BETA2 / iMac G5 revB (powerpc64 - radeon) - Bus Error 10

Emmanuel Chourdakis eruyome at gmail.com
Tue Sep 20 07:16:57 UTC 2011


I also sent my problem to the -ppc list but couldn't come to a conclusion.
I have a revB iMac G5(ppc64 - radeon based - not isight model) and I tried
installing freebsd9.0-beta2. I am using packages compiled from the ports tree.

I did X -configure as in the handbook, but when I tried X -config
I came up with this error: http://pastebin.com/v9qT8QU0

I also tried using/altering this configuration file:
but the "Bus Error: 10" kept appearing, at different places every time.

Of course I tried to rebuild world/kernel after original installation
and portsnap fetch/extract (I have this problem
for days now).

This is my dmesg: http://pastebin.com/eKuGXjUq
and this is my original xorg.conf.new:
http://slexy.org/view/s2ONa1YAEC (the xorg configuration
detected by Xorg -configure with UseFBDev False and NoAccel True).
Tried also to use the "ati" driver
instead of the radeon but with the same Bus Error: 10 message.

This is the result of "pciconf -lvbc": http://slexy.org/view/s21BKt4641

I'm a freeBSD newbie. I had some succesful x86/x86_64 installations in
the past with freebsd but I would like
to try to "revive" my iMacG5 using freebsd. I would glad if you could
direct me to find the problem.

Thank you for your answers.

More information about the freebsd-x11 mailing list