Request patch added to xorg-server in ports

Dustin Boontheekul dustin at
Mon Mar 23 16:41:35 PDT 2009


I've had issues with the xorg-server 1.5.x updates since they hit the
ports tree and kind of assumed it was just me not getting the upgrade
worked out right.  Up until this point, my fix had been to roll back
to 1.4.2.  I've tried to move forward again and run into the same
issue.  I hadn't seen posts on the mailing list describing it so I
decided to broaden my search.  Especially with most users' issues
having been resolved.  Well, I found this and it seems spot on:

They report having a fix too:

I am indeed using Xinerama on 3 screens (on 2 nvidia cards using the
nvidia driver) and a sure fire way to trigger it is when I'm using
synergy and moving to a remote screen.  I've applied the patch and
rebuilt xorg-server.  It seems to have fixed the issue for me.  I
should keep an eye on it for a few more days, but with synergy I could
trigger it on the first transition to a remote screen.  A few hours
with this patch and it's been solid.


Dustin Boontheekul

More information about the freebsd-x11 mailing list