ports/131016: x11/xorg - xorg-7.4 renders system unusable!

Toni Gundogdu legatvs at gmail.com
Tue Feb 3 02:20:09 PST 2009

The following reply was made to PR ports/131016; it has been noted by GNATS.

From: Toni Gundogdu <legatvs at gmail.com>
To: bug-followup at FreeBSD.org, ohartman at zedat.fu-berlin.de
Subject: Re: ports/131016: x11/xorg - xorg-7.4 renders system unusable!
Date: Tue, 3 Feb 2009 11:43:49 +0200

 Perhaps this is some help for those struggling with the Intel
 82845M (845M GMCH) like systems. Note that I have an USB keyboard
 and mouse connected to this system.
 I did the: # portupgrade -rf libxcb
 > Add Option "AllowEmptyInput" "off" to your ServerLayout section
 Did nothing for me except caused lockups. Not before or after
 the "20090124: AFFECTS: users of x11-servers/xorg-server,
 sysutils/hal" update.
 Pasting only the essentials:
 Section "ServerLayout"
     Identifier     "X.org Configured"
     Screen      0  "Screen0" 0 0
     InputDevice    "Mouse0" "CorePointer"
     InputDevice    "Keyboard0" "CoreKeyboard"
 # Had to add this after xorg 7.4 upgrade
 # USB devices (kb,mouse) would not be otherwise detected.
 Section "ServerFlags"
     Option "AutoAddDevices" "False"
 # This is left-over from 7.3, I haven't tried without it.
 Section "Extensions"
     Option "Composite" "Disable"
 Section "Module"
     Load  "GLcore"
     Load  "dbe"
 #   Load  "dri"
     Load  "extmod"
     Load  "glx"
     Load  "freetype"
 Section "Device"
     Identifier  "Card0"
     Driver      "intel"
     VendorName  "Intel Corporation"
     BoardName   "82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device"
     BusID       "PCI:0:2:0"
     # 7.3 left-overs, supposedly improved intel driver performance
     # Had something to do with XAA method if memory serves me right
     # Again, haven't tried without these three.
     Option      "AccelMethod" "EXA"
     Option      "ExaNoComposite" "false"
     Option      "MigrationHeuristic" "greedy"
     # DRI has been erratic since the 7.4 upgrade
     Option      "DRI" "false"
 Section "Screen"
     DefaultDepth 16
     SubSection "Display"
         Viewport   0 0
         Depth     16
 Probably worth noting that I had to add the following
 lines to /boot/loader.conf:
 Otherwise drm would fail at startx. 7.3 and DRI worked
 fine without them. I have, however, disabled DRI for 7.4
 since it turned out to be too erratic for my liking.

More information about the freebsd-x11 mailing list