x11-drivers/xf86-video-mga: current issues

Warren Block wblock at wonkity.com
Sun Jan 27 11:00:31 PST 2008

On Sat, 26 Jan 2008, Christian Weisgerber wrote:

> I just tried a Matrox G450 PCI on FreeBSD 8.0-CURRENT/amd64 with
> xf86-video-mga-1.4.7,1 and it locks up the machine.
> This card used to work fine for years in VGA mode up to Xorg 6.9
> on FreeBSD 5-STABLE/alpha.  Then X11 was reorganized and after I
> managed to get it to compile again, it would lock up the machine.
> Since I was pretty much the last guy running X11 on alpha, I gave
> up.
> Today I tried that card on 8.0-CURRENT/amd64.  Without xorg.conf
> the server complains about a missing fbdev module and quits.
> X -configure produced a sensible looking xorg.conf, though.  With
> that xorg.conf, the X server proceeds to start and LOCKS UP the
> entire machine.  So I guess it isn't only a problem on the moribound
> alpha.

Have you tried the xorg-server patch?  What about mga-1.9.100?

-Warren Block * Rapid City, South Dakota USA

More information about the freebsd-x11 mailing list