ports/120970: [radeon] Radeon Problems related to DRM and/or DRI

Hannes Hauswedell freebsd at soulrebel.in-berlin.de
Mon Feb 25 18:01:41 UTC 2008

I tried to use EXA for Accel, now X even crashes "just logging out".
I attached the backtrace below.

Also after using something that requires DRI I can't use the 
pseudo-terminals, because my screen tells me that the it can't display 
what its being fed. (I tried a second screen, same problem)

I have compiled wine with kthread support and now:
1) Starcraft works
2) when starting Warcraft3 randr seems to change the screen resolution 
10 or 15 times, then it loads Warcraft3. The menus have some funky  
display errors("rainbow colored rays"), but the game itself runs very 
=> No real Problems with wine so far (actually Warcraft3 performs better 
than with proprietary nvidia card and freebsd6)

When will xf86-video-ati-6.8 be in the ports? Maybe that will help...

Xorg-crash with accel=EXA
(gdb) bt
#0  0x28708f5a in DRILock () 
from /usr/local/lib/xorg/modules/extensions//libdri.so
#1  0x287b7ac5 in RADEONLeaveVT () 
from /usr/local/lib/xorg/modules/drivers//radeon_drv.so
#2  0x080a1ec8 in AbortDDX ()
#3  0x081b1f68 in AbortServer ()
#4  0x081b24b6 in FatalError ()
#5  0x080bf773 in xf86SigHandler ()
#6  <signal handler called>
#7  0x288bc742 in exaWaitSync () 
from /usr/local/lib/xorg/modules//libexa.so
#8  0x287ae43b in radeon_crtc_hide_cursor () 
from /usr/local/lib/xorg/modules/drivers//radeon_drv.so
#9  0x080eca5f in xf86CrtcConfigInit ()
#10 0x080ecab2 in xf86_hide_cursors ()
#11 0x080ecf9c in xf86_cursors_init ()
#12 0x287ae229 in RADEONCursorInit () 
from /usr/local/lib/xorg/modules/drivers//radeon_drv.so
#13 0x287b9861 in RADEONScreenInit () 
from /usr/local/lib/xorg/modules/drivers//radeon_drv.so
#14 0x0806d6bc in AddScreen ()
#15 0x080a25ec in InitOutput ()
#16 0x0806de46 in main ()

More information about the freebsd-x11 mailing list