xorg-7.3 and swapped CTRL_L and Caps_Lock

Kevin Oberman oberman at es.net
Sat Sep 15 16:43:35 PDT 2007

I run with the Caps Lock and Left Control keys swapped. I also run Gnome
which has a systems preference to set this. It worked fine until I
updated to xorg-7.3 and now, when the session starts, they are not
swapped and xemacs complains about improper keyboard configuration.

If I bring up the setup for the keyboard, it claims that the swap is
selected and, after exiting the setup window, they almost are. The only
remaining problem is that I have to press the ALT before I press CTRL to
have the combination accepted. If I press them together, the system only
sees the CTRL. (Note: I probably tend to hit CTRL slightly before ALT
when pressing them together.)

I suppose it's an interaction between xorg and xklavier, but it was fine
prior to the upgrade to xorg.
R. Kevin Oberman, Network Engineer
Energy Sciences Network (ESnet)
Ernest O. Lawrence Berkeley National Laboratory (Berkeley Lab)
E-mail: oberman at es.net			Phone: +1 510 486-8634
Key fingerprint:059B 2DDF 031C 9BA3 14A4  EADA 927D EBB3 987B 3751
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 224 bytes
Desc: not available
Url : http://lists.freebsd.org/pipermail/freebsd-x11/attachments/20070915/c9618ae4/attachment.pgp

More information about the freebsd-x11 mailing list