xorg 6.9-7.3 upgrade failure - assistance needed

Jose Antonio Galache jgalache at tlmat.unican.es
Mon Nov 26 01:21:48 PST 2007

Hi Jonathan,

I have a problem because I run first #portupgrade -Rr 'gstreamer*' and 
then portupgrade -a -x 'gstreamer*' and I could finish the upgrade (in 
my case from 6.9 to 7.2), so perhaps trying with portupgrade -a -x 
'gstreamer*', you could manage the already gstreamer ports installed.

After running this I got a stale dependency and I solved it it this way:

Stale dependency: bonobo-1.0.22_3->ghostscript-gpl-8.56_3 manually run 
'pkgdb -F' to fix or specify -0 to force

#pkgdb --Ff
It asks you to fix the dependencies, so you fix them.

Error: ghostscript --gpl not compatible with ghostscript-gnu

#portupgrade --o print/ghostscript-gpl ghostscript-gnu

Then, I followed with the commands indicated in the /usr/ports/UPDATING.

> freedsd-x11 devs,
> I failed upgrading xorg 7.3 following the /usr/ports/UPDATING entry 
> 20070519.
> Many components fail with the following: -
> No package 'fontconfig' found
> or
> No package 'xproto' found
> This is the first time I've followed this process so made the mistake 
> of running portupgrade -a while having some gstreamer ports installed.
> Thanks for any help you can give. I have the script output.......
> Thanks,
> Jonathan
> _______________________________________________
> freebsd-x11 at freebsd.org mailing list
> http://lists.freebsd.org/mailman/listinfo/freebsd-x11
> To unsubscribe, send any mail to "freebsd-x11-unsubscribe at freebsd.org"

I hope this can help you. Luck with it.


More information about the freebsd-x11 mailing list