Xorg and Intel 810

Jimmie James jimmiejaz at gmail.com
Sat Mar 3 21:24:03 UTC 2007

>I have this old Gateway Essential 933 that I just tried installing
>FreeBSD 6.2 on today. System installs fine, but I tried starting Xorg
>with its automatic config (can't remember the command but it's in the
>handbook)--gave me some funky colored vertical lines and locked up. Had
>to reboot, Ctrl-Alt-Bksp wouldn't kill it. Changed the driver to "vesa"
>in the config and tried it again, and then I got a greenish flickering

>Don't know what to try to fix this one. I'm brand-new to BSD but I've
>been with Linux for 3-4 years now, so I kinda know my way around.
>Immanuel Kant but Kubla Khan.

X is X, check your Xorg logs, your dmesg for any errors, I used to have 
an onboard i810, below is my X config that I was using for it.  It 
sounds like your modelines or h/v refresh rates are wrong, check the 
handbook for the various ways to set up X

         Identifier  "i810"
         Driver      "i810"
         VendorName  "Intel"
         BoardName   "82915G/GV/910GL Express Chipset Family Graphics 
         VideoRam    65536


The most likely way for the world to be destroyed, most experts agree, 
is by accident.
That's where we come in; we're computer professionals. We cause accidents.
(All typos are my typos, and they aren't up for grabs. All rights 
reserved 2006)

More information about the freebsd-x11 mailing list