intel 945GM, Beryl and Xorg 7.2RC3 troubles

sebosik at demax.sk sebosik at demax.sk
Thu Jan 4 17:09:58 PST 2007


Hi all

today I decided to try Beryl, so I compiled fresh system (RELENG_6 from
4.1.2006) - kernel + userland. Kernel got patch for AGP to see VGA.
Pkg_info shows nothing installed. Following guide on
wikitest.freebsd.org/ModularXorg, I compiled those packages only:

cd x11/xorg && make all install clean
cd x11-wm/icewm && make install clean
cd x11-wm/beryl && make install clean

then I configured X to user my intel 945GM  (laptop HP nx6310). In
xorg.conf section for Graphic card looks like this (short):

LoadModule "glx"
LoadModule "dri"
- Default color depth 24bpp @ 1024x768 -

...[VGA section]...
Driver "i810"
Option "DRI" "1"
Option "RenderAccel" "1"

Then I ran startx with icewm-session (through .xinitrc)... opened XTerm ->
 "beryl-manager" and voila: X went down like Titanic (something like "hard
panic.." or what).

Then compiled x11-clocks/glcock (because I can`t find glxinfo in xorg 7.2
RC3). Restarted X server, then I run "glclock" and I see that 3D
acceleration is only in software mode (Mesa Indirect :-| ).

Also tried to compile xorg-server without AIGLX. Beryl still knocks me out
from X after I run beryl-manager (in this speed I saw messages that he
cannot find glxinfo or what).


Any idea what is behind software mode only with Xorg 7.2RC3 ?

Best Regards
---
Jan Sebosik, Slovakia
sebosik [at]demax [dot]sk[2006]



More information about the freebsd-x11 mailing list