Xorg *still* hangs with ATI Radeon Mobility M10 (9700)

Ryan Avery rpavery79 at gmail.com
Wed Feb 7 22:49:44 UTC 2007

Hello all!

I'm going nuts trying to figure out why my video card doesn't work. I have a
ATI Mobility Radeon 9700 (recognized by Xorg as ATI RV350 [Mobility Radeon
9600 M10] For detailed background information (including my configuration
and conf files), see my december post here:


Basically, I have had a heckuva time getting DRI to work on this card. I
know r300 support is fairly new, but I see newer x700 and x800 cards that
are working. Since this is a laptop, I can't upgrade the card (otherwise I'd
go my an nVidia, though I know they have some problems too). I have an ASUS
x80k (very similar to the A2000 from what I can tell). In December I was
trying 6.2-PRERELEASE with xorg 7.2-RC2 with no luck. I gave up for a while
and tried again last night with 6.2-RELEASE on amd64 with xorg from git this
morning. Xorg still hung on startup. Then I saw Florent's post on this list
about recent commits to the drm source (updating the kernel radeon module to
1.25.0), so I upgraded to 6.2-STABLE a few hours ago and Xorg *still* hung
on startup. The same configuration works fine with the vesa driver, and also
works with the radeon driver but with dri commented out the xorg.conf, but
with this setup I get some intermittent screen corruption in the form of
vertical colored lines on the screen.

I have only ever had radeon working with DRI once on this laptop, exactly a
year ago, with Xorg 6.9.0 on 6.0-STABLE. However, after an upgrade in late
February 2006 I've never been able to figure out how to get DRI working
again (I even tried downgrading my FreeBSD to 6-STABLE as of 01-Feb-2006
last June, but that still didn't work. So I've stuck with vesa for the last
year. This is annoying for watching video since although mplayer -vo sdl
plays fullscreen, it's too slow at 1400x1050 resolution.

So, I have several questions:

1. Should I try FreeBSD-7-CURRENT? Are there considerable differences in
kernel DRM in CURRENT that have not been MFC'ed to 6-STABLE?

2. Does anyone else have this card (RV350 Mobility 9600 M10) working on
FreeBSD? If so, what is your configuration?

3. I can't imagine why it'd make a difference, but could it have anything to
do with amd64 issues? Should I try i386? I tried it last May but had the
same problem.

My symptoms seem to be fairly well described by this bug report -
https://bugs.freedesktop.org/show_bug.cgi?id=4847. This appeared to be fixed
by Ben Herrenschmidt back in December 2005 (**
http://lists.freedesktop.org/archives/xorg/2005-December/011678.html, a
later patch was applied to current). This patch was supposed to be applied
to ati- I know the ati-driver in the git tree is now at 6.6.3. I
imaging this patch was merged, but does anyone know more about this? The bug
report seems to imply that this card in particular causes trouble, but it
looks like the patch should have fixed this as indicated here:

I've been lurking on this list for quite a while - thanks to all of you
(especially you, Florent) who are doing the impressive task of getting
Xorg-modular into FreeBSD and testing it. I've learned a ton over the last
year, and I hope to help out someday (whenever I finish my PhD!). I'm aware
that this is likely an Xorg problem, and I may even file a bug report
upstream, but for now I'm hoping that some of you gurus can point out
something that I may be missing.

Thanks for your help!

More information about the freebsd-x11 mailing list