Xorg 6.9 completely locks up FreeBSD 6.0 - Known problem?

Fred Cox sailorfred at yahoo.com
Tue Mar 28 22:48:09 UTC 2006

I've been using FreeBSD 6.0 on a dual core 64 bit P4
for a couple of months.

After a ports upgrade last week, strange effects
started happening with X.  Some images being displayed
by KDE, Firefox, and Thunderbird did not display

Refresh of overlapped windows worked for a few
minutes, but then started failing.  Within a few
seconds of that, the machine locked up completely. 
Existing ssh sessions were dropped, CTRL-ALT-F? no
had no effect.  Even pushing the power button did not
do anything.  The screen was still displayed, but the
pointer stopped moving as well.  Pulling the power
plug was the only effective method.

The machine will run for an indefinite period if X is
not started.

Updating the kernel, the world, and the ports did not
solve the problem.

Reinstalling 6.0-RELEASE does solve the problem. 
Upgrading Xorg causes the problem to reappear.

The machine is a Dell XPS 400 dual core with ATI
Radeon X300 graphics using:

vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem
0xa0000-0xbffff on isa0

Disabling XMP in the kernel did not help.

Should I file a problem report, or is this being
worked on?

I can give network access to the machine, if someone
needs to look at it.

Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 

More information about the freebsd-x11 mailing list