XFree86-4 balls up

Eric Anholt eta at lclark.edu
Tue Jun 8 07:06:06 GMT 2004


On Tue, 2004-06-08 at 00:01, Matthew Gardiner wrote:
> On 8/6/04 11:47 AM, "Michael Nottebrock" <michaelnottebrock at gmx.net> wrote:
> 
> > On Tuesday 08 June 2004 02:29, Matthew Gardiner wrote:
> > 
> >> Here is the error:
> > 
> > [Possibly interesting output missing]
> > 
> >> erhaps you should add the directory containing `xrender.pc'
> >> to the PKG_CONFIG_PATH environment variable
> >> No package 'xrender' found
> >> checking for X... libraries /usr/X11R6/lib, headers /usr/X11R6/include
> >> checking X11/extensions/Xrender.h usability... yes
> >> checking X11/extensions/Xrender.h presence... yes
> >> checking for X11/extensions/Xrender.h... yes
> >> checking for XRenderFindStandardFormat... no
> >> configure: error: libXrender not found or too old.
> >> ===>  Script "configure" failed unexpectedly.
> >> Please report the problem to gnome at FreeBSD.org [maintainer] and attach the
> >> "/usr/ports/x11-fonts/libXft/work/libXft-2.1.6/config.log"
> > 
> > It would be nice if you could attach the abovementioned config.log. FWIW I
> > wonder why you didn't report that error plus requested information to
> > gnome at freebsd.org as suggested. No point in doing so now anymore however.
> > 
> >> As you can see, everything installs nicely until XFree86-4 clients.
> >> 
> >> As for how I am doing it, as I said in previous emails, I am building from
> >> the meta port XFree86-4, and when I start the build process nothing else is
> >> installed. It is a completely clean installation.
> >> 
> >> Btw, this has just recently occurred. Before I downloaded the mini-iso,
> >> installed, cvs'uped and everything was built nicely from the ports. That
> >> was just a couple of days ago.
> > 
> > I've tried to reproduce this in a clean jail running 5.2.1-RELEASE-p8 with
> > current ports (cvsup'd today) and building the XFree86-4 port worked fine all
> > the way as expected so I'm still not sure what's going wrong for you. Maybe
> > the config.log will help shed some light on the issue.
> 
> Well the issue won't be in config.log, the problem is, Xft2 is required for
> client, Xft2 relies on Xrender, but since there is no xrender.pc in the
> /usr/X11R6/libdata, which SHOULD exist if xrender is present, however, even
> though the files are present, the necessary "trigger" of xrender.pc doesn't
> exist.

No, the issue *will* be in config.log.  Because the most popular
suppliers of libXrender don't install xrender.pc, Xft2 doesn't require
it, though it prefers it to exist.  That's why it doesn't just bomb out
when it doesn't find xrender.pc.  Please follow what was asked and post
the config.log so someone can help with your problem.

> The worst part, Xrender then relies on libx11 which relies on etc. etc. In
> other words everything turned to crap when the individual parts of X11 were
> merged into the tree, before then everything worked nicely.

I already said you shouldn't install libXrender from ports, because you
already have it from XFree86-4-libraries.

-- 
Eric Anholt                                eta at lclark.edu          
http://people.freebsd.org/~anholt/         anholt at FreeBSD.org




More information about the freebsd-x11 mailing list