detaching usb device without unmounting it

Hans Petter Selasky hselasky at
Fri Jul 10 13:41:39 UTC 2009

This is not an USB issue.

Try -current.


On Friday 10 July 2009 11:05:48 Alexander Best wrote:
> since the usb2 stack allows one to detach a mounted usb device without the
> kernel panic'ing i'd like to know which steps are necessary to be taken
> after detaching a device? because i tried the following:
> 1. attach device
> 2. mount device
> 3. detach device
> when i tried to unmount the device i got the follwing error message:
> g_vfs_done():label/usb[WRITE(offset=19456, length=4096)]error = 6
> and the console got locked up (ctr+c didn't work). so i tried to reboot
> using ctrl+alt+del. however after the message: "All buffers synced" there
> was no reboot. so i had to do a hard reset. however after the reset freebsd
> fsck'ed my harddrives. so they didn't unmount properly.
> should i have used `umount -f`? or just plug the device back in again? or
> isn't it possible to unmount a device that has already been detached?
> i'm running r195476 btw.
> alex
> _______________________________________________
> freebsd-usb at mailing list
> To unsubscribe, send any mail to "freebsd-usb-unsubscribe at"

More information about the freebsd-usb mailing list