Problem with 16-in-1 card reader

John-Mark Gurney gurney_j at
Sat Mar 11 20:13:03 UTC 2006

Alex Dupre wrote this message on Sat, Mar 11, 2006 at 19:11 +0100:
> The problem arise when I replace the inserted CF with another one (with
> different size and filesystem, for example an MSDOS formatted card) and
> try to mount it. Fdisk can correctly
> sees the new partition table, but devfs is not updated and I cannot
> mount the new media. I tried to issue all sort of camcontrol commands
> (rescan the bus, eject and load the device, ...) but the dev entries
> remain unchanged (equal as boot time) even if the card is inserted or
> removed (camcontrol tur can see if the media is ready or not). If I
> issue new fdisk and bsdlabel write commands, the dev entries are updated
> (I created the boot CF exactly in this way), but I can't find a way to
> update them based on what is actually inserted.
> The system is a recent 6.1-PRERELEASE.
> Any ideas or suggestions? In there a way to SW unplug/replug the umass0
> device and let FreeBSD recreate the correct device nodes?

have you tried:
cat /dev/null > /dev/da0

That will force a reprobe of the geom layer for the da0 device by opening
it for write, and immediately closing it.

  John-Mark Gurney				Voice: +1 415 225 5579

     "All that I will do, has been done, All that I have, has not."

More information about the freebsd-usb mailing list