All my amd64 problems appear to be KSE

Tim Robbins tim at
Sat Jun 5 08:13:46 PDT 2004

On Sat, Jun 05, 2004 at 10:22:58AM -0400, Daniel Eischen wrote:
> On Fri, 4 Jun 2004, Sean McNeil wrote:
> > On Fri, 2004-06-04 at 21:06, Daniel Eischen wrote:
> > > On Fri, 4 Jun 2004, Sean McNeil wrote:
> > > 
> > > > I just switched over to libc_r via. libmap.conf and I no longer get any
> > > > mysterious crashes of applications in gnome.  My gnome-terminals and
> > > > everything else are just fine now.
> > > 
> > > How were you using libpthread?  It's best to use libmap.conf
> > > to map everything to libpthread so that libc_r isn't pulled
> > > in by libraries still linked to it.
> > 
> > This is a completely rebuilt machine from a working i386 install that
> > has tracked -current forever.  There is absolutely nothing that is
> > compiled and pointing to libc_r.
> Sorry, unless you have tried using libmap to map libc_r to
> libpthread, I don't trust that.

I can corroborate what Sean is saying. There is definitely something wrong
with KSE on amd64 (I haven't tried it on i386.) I've been chasing it down,
on-and-off, for about a month, but have come up with nothing so far.
gnome-terminal and xmms are two examples of applications that have gone
from unusable to usable after changing from libpthread to libc_r. Mozilla
may also be affected, but I'm less sure of that. The applications in
question just mysteriously vanish, sometimes with signal 10 or 11, sometimes
with no signal in the kernel log at all.


More information about the freebsd-threads mailing list