Intel(R) PRO/1000 PT Dual Port Server Adapter not working properly

Herbert J. Skuhra hskuhra at
Mon Mar 5 00:24:08 UTC 2012

On Sun, 4 Mar 2012 14:39:01 +0800
Irjohn Junus <i.junus at> wrote:

> Hello,
> This was originally posted here:
> I'm building a new PF firewall box based on FreeBSD 9 Release. Motherboard
> is Foxconn H61S Mini-ITX with Intel PRO/1000 PT dual port server adapter.
> The adapter is recognized as em0 and em1 but em0 just won't work (i.e no
> light on the port when connected to the switch) and em1 works only in
> 100baseTX full-duplex mode (no carrier if I force it to 1000baseT). I tried
> to change switch port, UTP cable from Cat5e to Cat6 but still no luck. The
> onboard Realtek works fine. Switch is Netgear GS608. Could it be a bad
> Intel card?
> I also tried to compile the latest driver from Intel but it gives error
> during compilation:
> Any help will be greatly appreciated. Thanks!
> ps: command captures are provided at the url above.

Maybe you should test with 8.3-BETA1. The recent em1000 drivers (7.3.0?)
were mfc'ed to stable/8 January 31st but not to stable/9.




More information about the freebsd-stable mailing list