FreeBSD hangs on boot after kernel upgrade to 9.0-R

mato gamato at
Sat Jan 21 23:24:37 UTC 2012

On Sat, 21 Jan 2012 22:57:05 +0200, Alexander Motin wrote
> Hi.
> On 01/21/12 21:34, mato wrote:
> > I've used freebsd-update to upgrade from 8.2-R to 9.0-R and all looked nice
> > until the first reboot.  Now my FreeBSD always hangs midway through the boot
> > process and the last message output is:
> > "uhub3:<Intel EHCI root HUB..."
> > I've tried safe boot option but that does not help at all.
> > When I disable USB support in BIOS the last message before hang is:
> > "ata1: reset tp1 mask=03 ostat0=00 ostat1=00
> > (aprobe0:ata0:0:1:0): SIGNATURE: eb14"
> >
> > Any idea what might be wrong and how to fix it please ?
> The last line is the ATAPI device detection. What ATA controller do 
> you have there? On one Core2Duo-class Supermicro system alike hang 
> was caused by ITE PATA controller. In that case it was workarounded 
> by adding hint.ata.0.mode="PIO4" to /oot/loader.conf. You may try 
> just set it from loader prompt with `set` command.

I don't know exact controller but this is Pentium M based laptop.
HDD is primary master while DVD drive is primary slave. :-/
And it's been working like this since FreeBSD 5.3.

Anyway, I've tried your advice but unfortunately it did not help.
Here is longer log (retyped from screen):

ata0: reset tp1 mask=03 ostat0=50 ostat1=00
ata0: stat0=0x50 err=0x01 lsb=0x00 msb=0x00
ata0: stat1=0x00 err=0x01 lsb=0x14 msb=0xeb
ata0: reset tp2 stat0=50 stat1=00 devices=0x20001
(aprobe0:ata0:0:0:0): SIGNATURE: 0000
ata1: reset tp1 mask=03 ostat0=00 ostat1=00
(aprobe0:ata0:0:1:0): SIGNATURE: eb14"

Then it hangs.  And please note it looks differently when USB is not turned
off in BIOS.  Though I have no idea if / how that matters.

So what now please ?  Any other things to try ?



Freehosting PIPNI -

More information about the freebsd-stable mailing list