linux-f10-flashplugin

Conrad J. Sabatier conrads at cox.net
Wed Sep 28 16:50:20 UTC 2011


On Wed, 28 Sep 2011 19:59:43 +0400
"S.N.Grigoriev" <serguey-grigoriev at yandex.ru> wrote:
> 
> Hi Conrad,
> 
> after manual reinstalling as described above 'npconfig -l' output is:
> 
> /usr/local/lib/browser_plugins/npwrapper.libflashplayer.so
>   Original
> plugin: /usr/local/lib/npapi/linux-f10-flashplugin/libflashplayer.so
> Plugin viewer: /usr/local/lib/nspluginwrapper/i386/linux/npviewer
> Wrapper version string: 1.4.4-1
> 
> Still no results.
> 
> Regards,
> Serguey.

OK, your output differs from mine in only one respect.  Mine shows the
following:

/home/conrads/.mozilla/plugins/npwrapper.libflashplayer.so
  Original
plugin: /usr/local/lib/npapi/linux-f10-flashplugin/libflashplayer.so
Plugin viewer: /usr/local/lib/nspluginwrapper/i386/linux/npviewer
Wrapper version string: 1.4.4-1

It was a while ago that I did the actual wrapper install, but if I
remember right, I simply copied npwrapper.libflashplayer.so
from /usr/local/lib/browser_plugins to /home/conrads/.mozilla/plugins.
You may want to try doing that and see if firefox/chromium will then
recognize it.

In theory, the system-wide install under /usr/local/lib/browser_plugins
*should* work, but I seem to recall having problems with it, which was
why I tried putting it under ~/.mozilla/plugins.  Maybe it has
something to do with the fact that it's not a native plugin(?).  I
don't know, really.  But this has worked fine for me ever since, even
across upgrades.

Hope this helps.  Let us know how it turns out.

-- 
Conrad J. Sabatier
conrads at cox.net


More information about the freebsd-stable mailing list