FreeBSD 8.0 SCSI Boot

Doug Hardie bc979 at
Sat Mar 27 21:10:29 UTC 2010

On 27 March 2010, at 13:37, Peter Jeremy wrote:

> On 2010-Mar-26 17:18:30 -0700, Doug Hardie <bc979 at> wrote:
>> I tried to upgrade a 7.2 system to 8.0.  It uses a SCSI drive.  It
>> works fine on 7.2.
> We will need some more details before we can help you.
>> However, it would appear that during the upgrade
>> process when running make delete-old (?) there is a note about make
>> delete-old-libs (?).  Don't do that at that point.  End of system.
>> Make installworld fails miserably.
> You shouldn't run either "make delete-old" or "make delete-old-libs"
> until you have successfully run "make installworld" - the upgrade
> procedure shows delete-old after installworld.  Whilst delete-old will
> just make it harder to revert from a failed upgrade, running
> delete-old-libs will prevent you running installworld.  When you run
> delete-old-libs, it warns you "Please be sure no application still
> uses those libraries, else you can not start such an application."
> One application that needs the old libraries is installworld.

I know that now.  Probably should have before, but didn't figure it out.  Not having access to UPDATING made writing the original message a bit difficult.  make delete-old was run after make installworld.  When it completes it says you can run make delete-old-libs.  That is where I made the first mistake.  I believe that message is quite misleading and should be removed.  The first failure occurred on mergemaster not make installworld.  It died on the second install file.  The error was something to the effect that rw on /etc/fstab was invalid and gave the sysctl settings to use in boot to get around it.  There was nothing other than a reboot possible at that point.  There was no other option.

>> Unfortunately rebooting caused numerous problems.
> Given that your installworld had failed - presumably leaving various
> FreeBSD-7.2 files lying around, whilst you deleted the libraries
> required by some of them, this is not surprising.
>> First the /etc/fstab was listed as corrupt.
> This is surprising.  Assuming you cleanly rebooted your system, it
> is very unlikely that your /etc/fstab was corrupted and is more likely
> a problem with one of the mount programs.
> Can you provide the exact error message and what you then did.

that information is long gone.

>> Then it quit booting altogether.
> If it rebooted once, there's no reason why it shouldn't reboot a
> second time.  What actions did you take between the two reboots and
> what exactly do you mean by "quit booting"?

It dies in the boot laoder with F1 followed by numeous #s.

>> A complete reload from the disc 1 goes
>> nowhere either.  It installs just fine but when it goes to reboot,
>> All I get is F1 followed by a bunch of increasing #s.  Any key just
>> adds more to the list.  I have tried with both the standard and
>> FreeBSD boot managers with the same result.
> At that point, FreeBSD is using the BIOS drivers to access the SCSI
> disk.  If you get the 'F1' prompt then the BIOS is correctly loading
> the boot sector (so it can access the disk) so there is no obvious
> reason why it isn't booting.
> Do you have a copy of the dmesg from 7.2?  If not, can you give us
> some details about your motherboard (vendor/model), what SCSI
> controller you are using, what targets are attached and what other
> disks (if any) you have.  Are you using a PS/2 or USB keyboard?

The 7.2 stuff is long gone.  The disk has been wiped several times.  Until I can get past the F1 issue I don't have access to the hardware information.  It uses a PS/2 keyboard and is i386 32 bit.  Its an AMD processor thats quite old.

> Can you expand on what you mean by "a complete reload" - did you do a
> full install of FreeBSD 8.0, including partitioning and creating disk
> slices or did you re-use the existing slices?  Are you using a
> "dangerously dedicated" disk?  Were any disk geometry errors reported?

Complete reload means with the live filesystem:

dd if=/dev/zero of=/dev/da0 bs=10240 count=100
Boot from Disc 1
Follow the Standard Install option is sysinstall

I have done that 4 times now.  There was a semi-dead ad0 disk in the unit.  That has been removed and going through the above one more time at this moment.

There were no errors reportd for disk geometry and its not dangerously dedicated.  I gave up with that on version 2.7.

This time it worked.  I used the first boot manager entry, not the FreeBSD Boot manager and there is no F1 line.  It just boots into FreeBSD.  Thats fine since there is only FreeBSD on the machine.  I guess something from the ad0 drive was interfering with the boot.  The disk was reporting numerous write errors although it could be read fine and was only holding archive'd data.  Its loss is insignificant.

I believe the big issue where was the message about make delete-old-libs that make delete-old outputs. I had never tried that before and never had problems.  This time I decided to try it.  I think that message should be removed.

> -- 
> Peter Jeremy

More information about the freebsd-stable mailing list