8.x grudges

Mikhail T. mi+thun at aldan.algebra.com
Thu Jul 8 22:10:52 UTC 2010

08.07.2010 17:06, Peter Jeremy написав(ла):
> On 2010-Jul-07 14:22:22 -0400, "Mikhail T."<mi+thun at aldan.algebra.com>  wrote:
>> In no particular order:
>>    1. A picture, that one of the systems was displaying at boot (and
>>       then used as a screen-saver),  stopped showing properly. The
>>       colors are right, but the picture is distorted beyond recognition.
>>       The relevant part of loader.conf is:
>>           splash_pcx_load="YES"
>>           vesa_load="YES"
>>           bitmap_load="YES"
>>           bitmap_name="/boot/187426-9-quokka-dreaming.pcx"
> It's a bit difficult to provide any useful input without some idea
> of what the picture should and does look like.  Can you please post
> the actual bitmap as well as a picture of your screen showing the
> problem.
I don't want to post it publicly for copyright reasons. I can e-mail it 
to you (or anyone else) directly, though.
>>    3. Likewise, having "device ugen" breaks config(8) -- another
>>       undocumented incompatibility.
> Can you please advise where it is documented that "device ugen"
> is valid in a FreeBSD-8 config file?
It was a valid device for FreeBSD-7. The UPDATING-file enumerates a 
number of things, that need to be changed, when updating to 8, but the 
removal of "ugen" is not mentioned there.
>>    5. One of the upgraded systems would repeatedly hang at boot, until I
>>       disabled the on-board firewire-device through the BIOS... It was
>>       not a problem under 7.x, although I don't know, whether the device
>>       actually worked.
> I haven't seen this on any of my systems.  Can you please provide
> details of your motherboard, BIOS and the output from a verbose boot
> up to the hang.  Is there a BIOS update available and have you tried
> installing it?
No BIOS updates :-( I can e-mail boot's output to you directly (please, 
confirm interest). It would be with the device disabled though, because 
the boot never completes, if it is enabled.
>>    6. Despite the reported improvements in the USB area, my USB keyboard
>>       /still/ does not work during boot. It during POST and then after
>>       the booting is complete. But in single-user mode -- no... Had to
>>       fish-out the PS2 keyboard...
> I have had similar problems on one of my USB-only desktops.  In my
> case, moving the keyboard to a different USB port solved the problem.
> All I can suggest is to work your way through all the USB ports you
> have available and see if they all behavee the same.
I'll try that next time I reboot this system. Thanks,


More information about the freebsd-stable mailing list