NFS permission strangeness

Giulio Ferro auryn at
Fri Apr 16 08:24:27 UTC 2010

On 16.04.2010 02:30, Rick Macklem wrote:
>> login as "giulio", but when I try to access that same dir on the 
>> client machine
>> I get:
>> $ cd /path/to/root/dir/etc
>> (ok)
>> $ cd subdir2
>> subdir2/: Permission denied.
> What happens is that I can access "subdir2" on the server machine when I
> Yes, it should work. I just tried the same thing with a server running
> UFS/FFS and it worked fine, so I think that the problem might be ZFS 
> related. (You will get into trouble with more than 16 groups, since
> that is all that AUTH_SYS for Sun RPC handles, but I did 10 like your
> example and it worked ok for me, using FreeBSD-CURRENT client/server,
> except that my server uses UFS/FFS.)
> Hopefully someone with ZFS expertise can help out here?
> If you can conveniently do the same test using a server that exports
> a UFS/FFS file system, that would be helpful w.r.t. isolating the
> problem.
> rick

Yes, I have more than 16 groups, 22 actually...

However I still think this might be a NFS problem, since when I login on
the server machine I can access that directory all right, the problem arises
only when I try to access that dir in the client machine...


More information about the freebsd-stable mailing list