ZFS booting without partitions (was: ZFS boot on zfs mirror)

Adam McDougall mcdouga9 at egr.msu.edu
Sun May 31 07:18:02 UTC 2009

I encountered the same symptoms today on both a 32bit and 64bit
brand new install using gptzfsboot.  It works for me when I use
a copy of loader from an 8-current box with zfs support compiled in.
I haven't looked into it much yet but it might help you.  If you
want, you can try the loader I am using from:

On Thu, May 28, 2009 at 10:41:42PM +0200, Lorenzo Perone wrote:

  On 28.05.2009, at 21:46, Mickael MAILLOT wrote:
  > hi,
  > did you erase gmirror meta ? (on the last sector)
  > with: gmirror clear ad6
  ohps I had forgotten that. just did it (in single user mode),
  but it  didn't help :( Shall I repeat any of the other steps
  after clearing gmirror meta?
  thanx a lot for your help...
  > 2009/5/28 Lorenzo Perone <lopez.on.the.lists at yellowspace.net>:
  >> Hi,
  >> I tried hard... but without success ;(
  >> the result is, when choosing the disk with the zfs boot
  >> sectors in it (in my case F5, which goes to ad6), the kernel
  >> is not found. the console shows:
  >> forth not found
  >> definitions not found
  >> only not found
  >> (the above repeated several times)
  >> can't load 'kernel'
  >> and I get thrown to the loader prompt.
  >> lsdev does not show any ZFS devices.
  >> Strange thing: if I boot from the other disk, F1, which is my
  >> ad4 containing the normal ufs system I used to make up the other
  >> one, and escape to the loader prompt, lsdev actually sees the
  >> zpool which is on the other disk, and shows:
  >> zfs0: tank
  >> I tried booting with boot zfs:tank or zfs:tank:/boot/kernel/kernel,
  >> but there I get the panic: free: guard1 fail message.
  >> (would boot zfs:tank:/boot/kernel/kernel be correct, anyways?)
  >> Sure I'm doing something wrong, but what...? Is it a problem that
  >> the pool is made out of the second disk only (ad6)?
  >> Here are my details (note: latest stable and biosdisk.c merged
  >> with changes shown in r185095. no problems in buildworld/kernel):
  >> (....)
  freebsd-stable at freebsd.org mailing list
  To unsubscribe, send any mail to "freebsd-stable-unsubscribe at freebsd.org"

More information about the freebsd-stable mailing list