gstripe problem

Nenhum_de_Nos matheus at
Sat Jul 18 00:01:22 UTC 2009

On Fri, July 17, 2009 09:07, Nenhum_de_Nos wrote:
> On Fri, July 17, 2009 07:20, Ivan Voras wrote:
>> Nenhum_de_Nos wrote:
>>> hail,
>>> I have a problem with gstripe on today stable. I created this stripe
>>> using a bit more old stable (two weeks tops) and it can't be read on
>>> old
>>> stable (from 30/12/2008). So I recreated in 8-BETA1 and I could mount
>>> and see files. When I tried again on 30/12/2008 stable and todays, on
>>> PII machine (i386):
>> So your problem is that:
>> a) you created a gstripe array on a recent STABLE (two weeks ago) and it
>> was fine
>> b) you tried to use it with an old STABLE (30.12.2008.) and it didn't
>> work
>> c) you tried to use it with today's STABLE and it didn't work
>> d) it works with 8-BETA1
>> ?
> its quite this. the stripe just vanishes when I try to see it in any
> stable. and if I create in stable, a reboot makes it go way :(
>> The only thing that comes to my mind is that during your tests you have
>> changed the stripe size, making the file system data unusable (and
>> unmountable).
>>> [root at xxx ~]# gstripe status
>>>           Name  Status  Components
>>> stripe/stripe0      UP  ad4s2
>>>                         ad6s2
>>> mount: /dev/stripe/stripe0 : Invalid argument
>>> on 8-BETA1 it works, but can't create stripe on it and use on this
>>> stable box though. the stripe already has files ! so anything weird
>>> could make me loose my data ...
>> Are you saying you won't use 8-BETA1 because you fear there may be
>> problems with it? If so, you shouldn't worry so much - 8-CURRENT is very
>> stable.
> I know it is. 8-CURRENT is great really (I use it in other places). my
> main concern is that this is a server with mail/dns/dhcp/apache/some other
> services I forgot and changing to 8-BETA may need to recompile all things,
> and need time I don't have right now ...
> can I just update and use all software compiled for 7.1-PRERELEASE ?
> thanks,
> matheus

thins here just got weird. I did updated to 8-BETA2. same problem though.
so I just thought it was problem when I create a stripe in amd64 machine
and try to use it on i386.

I then put the drives in the amd64 machine, and it did worked fine, after
another gstripe create command. so I rebooted the amd64 machine to see if
after reboot the stripe would be there. guess what ... nothing there ...

I used gmirror and gstripe for about an year, no problem. couple of months
ago I had a problem and had to change the pc (dead one). so all changed,
using sil3114 sata pci card now and PII 300 MHz. now the disks behave like

if anyone has any leads, I'm moving data from the disks now ... can test



We will call you cygnus,
The God of balance you shall be

A: Because it messes up the order in which people normally read text.
Q: Why is top-posting such a bad thing?

More information about the freebsd-stable mailing list