Error when using 'portupgrade -ay' (and several others) [Second attempt]

Greg Miller gmiller at
Sat Aug 1 18:14:02 UTC 2009

Jens Rasmus Liland wrote:

> So what command am I supposed to run?
> On Sat, Aug 1, 2009 at 4:50 PM, Barney Wolff <barney at> wrote:
>> I got around this by using -k.  Dependencies are a maze of twisty
>> little passages, all alike.  I'll take my chances with the grue.
>> On Sat, Aug 01, 2009 at 04:17:17PM +0200, Jens Rasmus Liland wrote:
>>> Hi,
>>> I'm getting really weird problems when trying to upgrade my ports. I've
>>> already discussed this with Dan Naumov on the stable mailing list, and he
>> is
>>> out of ideas on what I am to do. I've tried to fix the problem using many
>>> different methods (i.e. csup stable-ports-supfile; Portmaster -a/-af,
>>> portupgrade -ay, nuking the entire ports tree and then doing fetch ports;
>>> extract, and similar stuff), but everyone seems to get the same error,
>> and
>>> not come any further. The ports my system is trying to update is not in
>> the
>>> ports tree anymore either, so it is really strange that it is trying to
>>> update it self.

And a pkgdb -F didn't take care of this?
-- |
      Any government that can give you everything you want
                  can take everything you have.

More information about the freebsd-stable mailing list