Error when using 'portupgrade -ay' (and several others) [Second attempt]

Barney Wolff barney at databus.com
Sat Aug 1 15:32:14 UTC 2009


I got around this by using -k.  Dependencies are a maze of twisty
little passages, all alike.  I'll take my chances with the grue.

On Sat, Aug 01, 2009 at 04:17:17PM +0200, Jens Rasmus Liland wrote:
> Hi,
> 
> I'm getting really weird problems when trying to upgrade my ports. I've
> already discussed this with Dan Naumov on the stable mailing list, and he is
> out of ideas on what I am to do. I've tried to fix the problem using many
> different methods (i.e. csup stable-ports-supfile; Portmaster -a/-af,
> portupgrade -ay, nuking the entire ports tree and then doing fetch ports;
> extract, and similar stuff), but everyone seems to get the same error, and
> not come any further. The ports my system is trying to update is not in the
> ports tree anymore either, so it is really strange that it is trying to
> update it self.
> 
> Here is some outputs I've already posted on the stable mailinglist:
> 
> Running 'portupgrade -ay'. Got this output:
> 
> --->  Session started at: Fri, 10 Jul 2009 18:58:30 +0200
> ** Port directory not found: x11-drivers/xf86-video-vga
> ** Port marked as IGNORE: x11-drivers/xf86-video-via:
>     requires pciVideoPtr typedef
> ** Port directory not found: x11/xorg-protos
> ** Port directory not found: x11/xphelloworld


More information about the freebsd-stable mailing list