BTX loader hangs after version info

James Seward jamesoff at
Sat May 24 16:34:59 UTC 2008

`On Fri, May 23, 2008 at 11:11 PM, John Baldwin <jhb at> wrote:
> [patch]

I have not yet tried this patch, but here is my progress so far:

* Rolling back to 7.0-RELEASE made it worse - now after choosing
FreeBSD from grub the machine would immediately reboot.
* I booted with the CD again and came forward to RELENG_7. This still
caused an immediate reboot.
* I booted with the CD and replaced grub with "boot0cfg -B" (bsdlabel,
which I tried earlier, had no effect). This fixed it, mostly.

My desktop now boots fine and completes normal startup. It even starts
X. However, from the moment I press F1 to choose FreeBSD to the moment
it's done booting, all I see on the screen is "BTX loader 1.00 BTX
version is 1.02" and the cursor blinking below it. My only clues that
it's booting at the time are disk activity, and the cursor changing
from a flashing underline to a solid block (which it always has as the
kernel proper takes over).

The next thing I see is "FreeBSD/i386 ( (ttyv0)". I
have also noticed that I don't get any output when I restart - no rc.d
scripts telling me things are stopping, no vnodes syncing, nothing.
It's apparently happening though, as everything is
starting/stopping/umounting correctly.

I don't see that I have anything configured to boot to serial rather
than the console, but is there anything I can do/check to make sure
this definitely isn't happening? Unfortunately, putting a cable on the
serial port is not an option as I currently do not own one suitable :)


More information about the freebsd-stable mailing list