recovering from the 6.3 xorg mess

Robert Chalmers robert.a.chalmers at
Mon Mar 17 01:11:33 PDT 2008

Well, I suppose this will eventually get to the original poster.

I too have just gone through this nightmare. But, I short circuited it all.

I went to a clean install of 7.0-RELEASE.

Ah ha. Easy. Nope.  The gremlins were waiting.

So basically here's what I did.

When I loaded the new system, I installed EVERYTHING I could enable. If
there was an option, I installed it.
Rebooted - X blah blah blah .... of course not.
Fiddled with the xogconfig and made lots of xorg.config attempts, then
realised - looking at the log - that it couldn't find the S3 driver. Yes,
ancient S3 card in this box. All of 8 years old.
So - took a clue from the log, and went into I think, like,
....xorg-drivers, and looked at the Makefile, which had everything in it. I
commented out the things I would never need - mouses, and video - which is
all that is in there, and left in the obvious ones, including some that
"might come in handy one day" and typed 
Make install clean
Now it all works. Well, as soon as I figure out some of the other mystical
incantations - worse than World of War this lot.

But bottom lline.
Go into that xorg-driveers directory and check the Makefile, then "make
install clean" and lots of things start happening.

And I add - this is after a clean install where I said "Just do it" ... yea
right. :-)

Sorry I can't check those directories - I'm currently trying to port in VNC
.... I live in hope.

-----Original Message-----
From: owner-freebsd-stable at
[mailto:owner-freebsd-stable at] On Behalf Of Brad Pitney
Sent: Monday, 17 March 2008 4:39 PM
To: peter stern
Cc: freebsd-stable at
Subject: Re: recovering from the 6.3 xorg mess

On Mon, Mar 17, 2008 at 5:29 AM, peter stern <pstern at> wrote:
> I'd appreciate suggestions on how to get a working xorg from the mess 6.3
>  shipped with. I've been using FreeBSD since 2.2 and have never had much
>  trouble with it until the 6 branch was released. My hardware is pretty
>  generic Intel brand D865 motherboard, matrox g550 video. I don't
>  the kernel. I do clean installs not upgrades.

have you tried without an xorg.conf?

>  The xorg in 6.3 doesn't install much in the way of required drivers. I
>  the mouse and keyboard drivers installed and also the mga driver. I have
>  run xorgconfig to create what seems like a working xorg.conf. Startx
>  brings up twm but only in 640x480. I cannot change modes. And yes, I have
>  mode lines defined. If I put the correct horizontal and vertical scan
>  rates in for my Viewsonic PT810 monitor, I get a screen display with
>  precessing through it. xdm gives the same result.
>  I have tried the other suggestions on configuring X in the FreeBSD
>  handbook, including creating a basic xorg.conf. It tests okay but only in
>  640x480 and it has no modelines in the .conf. Adding modelines doesn't
>  the problem.

I suspect modelines won't help and there might be a bug in xf86-video-mga?

>  The initial install was done by sysinstall under the predefined
>  xdeveloper selection. I tried reinstalling xorg from ports by running
>  deinstall and make reinstall but with no change in behavior.

what about installing just base then using an up-to-date ports?

>  My hardware has no problems running Slackware 12 or Openbsd 4.2. Under
>  those OSs, X11 works fine and configures without problems.
>  What has happened to quality control in the FreeBSD release?

is it really a FreeBSD issue?

>  peter

Best regards,
freebsd-stable at mailing list
To unsubscribe, send any mail to "freebsd-stable-unsubscribe at"

More information about the freebsd-stable mailing list