Recent bootloaders not working also on FIC PA-2005 board

John Baldwin jhb at
Thu Apr 10 21:14:14 UTC 2008

On Wednesday 09 April 2008 04:32:48 pm Marcin Cieslak wrote:
> > It would be these changes.  Debugging this will be hard. :(  Are you 
> > with x86 assembly at all?
> > 
> I have a bit different problem: The box (old Pentium-MMX PC with the FIC
> PA-2005 board using VT82C580 (Apollo VP) chipset. The machine had 16MB
> RAM only, recently upgraded to 256MB.
> I have installed the newest BIOS version available, so the CD-ROM
> booting works properly. I can boot Solaris 8 for Intel CD and NetBSD 4.0
> install CD, but FreeBSD CDROMs from 5.5-RELEASE, 7.0-RELEASE and March
> 2007 8.0-CURRENT bootloaders fail in the same way:
> - A /boot/loader menu appears. The cursor runs like around "10 seconds"
> countdown, like "10" was printed and then 3 backspaces and 10 printed
> again, no countdown takes place.
> - Pressing some keys like Enter, Space and "3" - nothing happens, but if
> you persist long enough (with "3" or "Enter") you can make the counter
> running down.
> - After the counter expires, the |/-\|/- progress meter (how do we call
> this thing?) appears for a while and then the system resets.
> How can I try to debug this? I have tried to attach serial console
>   with AT keyboard unplugged I still get message that VGA console will
> be used. The serial port is working correctly (verified with Windows and
> later with NetBSD).

CD-ROM booting uses a separate bootstrap (src/sys/boot/i386/cdboot/cdboot.s).  
It does depend on a non-ancient BIOS.  NT 4.0 uses the same CD booting method 
that newer FreeBSD snaps use FWIW.  To debug this you would need to hack on 
cdboot.s to find out when and where it dies.

John Baldwin

More information about the freebsd-stable mailing list