USB keyboard locking up on 7-RELEASE/amd64

H. Wade Minter minter at
Wed Apr 9 22:26:51 UTC 2008

I have a Dell Optiplex 755, with an Intel Core 2 Duo chip.  I have  
installed 7-RELEASE/amd64 on it.  2GB of RAM, 6GB of swap.

The install went fine, but post-install I'm running into a problem  
where the USB keyboard will just lock up.  I can still ping and SSH  
into the system, but after about 2 minutes of activity, the keyboard  
becomes nonresponsive.

I can move the USB plug to a different port, and see that it's  
recognize, and the keyboard comes back, but a couple of minutes later,  
it locks again.

I've checked with things in the BIOS, but can't find any setting that  
makes a difference.  I've tried both the 4BSD and ULE scheduler, no  

Any thoughts or known issues that would explain this?  When the lockup  
happens, there's nothing in /var/log/messages or dmesg to indicate a  

The only other clues are that sometimes, right before it locks, it  
will go into a repeat loop on a keypress, and it seems to be able to  
be reliably triggered by switching virtual consoles (though not  

I've tried different keyboards, so it doesn't appear to be a hardware  



More information about the freebsd-stable mailing list