Can't boot freebsd from usb device - Invalid slice

Jeremy Chadwick koitsu at
Tue Jun 12 17:20:31 UTC 2007

On Tue, Jun 12, 2007 at 08:32:03PM +0400, WaW wrote:
>  Hello.
>  I'm trying to install freebsd 6.2-STABLE to usb device. After
>  installation done successfully and reboot i getting messages like
>  this:
>  Invalid slice
>  Invalid slice
>  No /boot/loader
>  FreeBSD/i386 boot
>  Default: 0:ad(0,a)/boot/kernel/kernel
>  boot:
>  typing "da(0,a)/boot/loader" and many other variants had no success.
>  Also i tried to install manually, allocating full disk for bsdlabel
>  slice - same result.
>  My motherboard is asus a8n-sli premium, and it is capable of booting
>  from usb. Recently i successfully installed and booted opensuse from
>  the same usb device.
>  Is there any solution to make freebsd boot from usb device?
>  PS as usb device i mean my usb flash and ata disk with external case,
>  i tried both of them.

I believe this has been discussed before.  The conclusions I remember
being reached were that the FreeBSD bootloader has issues when trying
boot USB disks (pendrives, CF, hard disks, etc.).

Using something like GRUB (yes, to boot FreeBSD) instead apparently
works fine.  It's in ports; sysutils/grub.

| Jeremy Chadwick                                    jdc at |
| Parodius Networking                  |
| UNIX Systems Administrator                      Mountain View, CA, USA |
| Making life hard for others since 1977.                  PGP: 4BD6C0CB |

More information about the freebsd-stable mailing list