HP Desktjet D1420 detected by Freebsd, but not CUPS

John Walthall jzw at authority.vistua.com
Fri Jul 13 21:56:04 UTC 2007

On Fri, 13 Jul 2007 19:32:26 +0200
Torfinn Ingolfsen <torfing at broadpark.no> wrote:

> Have you tried restarting cupsd and hpiod, hpssd in the correct order?
> Does hp-toolbox say anything interesting if you try to run it?
Yes, I dried all the obvious, HP-toolbox says " No devices
found.Please make sure your printer is properly connected and powe
> IIRC, you need a kernel without ulpt (I don't remember if it is in
> GENERIC or not), and also without umass if your printer has memory
> card slots.
Indeed, I had anticipated this and configured appropriatly, ulpt
does not exist in my custom kernel.
> Hmm, I used cups web interface to setup my printer, but don't remember
> how (it is many versions ago). I suspect that the printer just showed
> up and I just selected it.
I guess, that's how it worked back in my Linux days. (but that too,
was many versions ago)

Now the pith of the matter. I also emailed Mr. Mistry, the maintainer;
and he says "Your printer needs a newer version of hplip that isn't in
the ports yet.  I'm planning on submitting and update this weekend."
So, I'll wait! Thank you all very much for your help; I'll give the list
a post when I try this.

--Thank you.

More information about the freebsd-stable mailing list