out of memory in restore?

Dmitry Pryanishnikov dmitry at atlantis.dp.ua
Wed Oct 25 10:25:13 UTC 2006


On Tue, 24 Oct 2006, Yoshihiro Ota wrote:
> I think you have to extend your user space memory by adding the
> following to /boot/loader.conf.  If 5.4-RELEASE doesn't support
> these options, adjust your kernel.
> kern.maxdsiz="2048m"
> kern.maxssiz="1024m"

   Well, the original poster didn't mention whether he's tried to restore in
single or multiuser mode. This actually makes a big difference. On my RELENG_6
test system (csup-ped and rebuilt as of 24-Oct-2006) I still see that process
resource limits in singleuser mode are _way_ too low. Here is multiuser mode 
root limits (as set in /etc/login.conf; system-wide limits are even higher as
I have kern.max{d,s,t}siz="1G" in my /boot/loader.conf):

root at test# limits
Resource limits (current):
   cputime          infinity secs
   filesize         infinity kB
   datasize           524288 kB
   stacksize          524288 kB
   coredumpsize     infinity kB
   memoryuse          131072 kB
   memorylocked        65536 kB
   maxprocesses          512
   openfiles             600
   sbsize           infinity bytes
   vmemoryuse       infinity kB

However when I reboot into the singleuser mode (boot -s from the loader 
prompt), I see the following:

# swapon -a && mount -a && limits -B
Resource limits (current):
   cputime          infinity secs
   filesize         infinity kB
   datasize-max      1048576 kB
   datasize-cur       131072 kB
   stacksize-max     1048576 kB
   stacksize-cur        8192 kB
   coredumpsize     infinity kB
   memoryuse-max    infinity kB
   memoryuse-cur     1016100 kB
   memorylocked-max  1016100 kB
   memorylocked-cur   338700 kB
   maxprocesses         6164
   openfiles           12328
   sbsize           infinity bytes
   vmemoryuse       infinity kB

I fail to see where those super-low datasize-cur and stacksize-cur get set
(the aren't in /.profile nor in /etc/profile nor in ~root/.profile), but
they could prevent using the memory-hungry application (I suppose I can call
restore a memory-hungry).

> Hiro
> On Tue, 24 Oct 2006 10:08:01 +0400
> Alex Povolotsky <tarkhil at webmail.sub.ru> wrote:
>> Hello!
>> I've tried an interactive restore from a dump, and glob fails, so
>> restore fails with "out of memory". Is my dump useless now?
>> (dumped and tried to restore under 5.4-RELEASE)
>> Alex.

Sincerely, Dmitry
Atlantis ISP, System Administrator
e-mail:  dmitry at atlantis.dp.ua
nic-hdl: LYNX-RIPE

More information about the freebsd-stable mailing list