out of memory in restore?

Jeremy Chadwick freebsd at jdc.parodius.com
Wed Oct 25 05:25:16 UTC 2006

On Tue, Oct 24, 2006 at 10:08:01AM +0400, Alex Povolotsky wrote:
> Hello!
> I've tried an interactive restore from a dump, and glob fails, so 
> restore fails with "out of memory". Is my dump useless now?
> (dumped and tried to restore under 5.4-RELEASE)

FWIW, I've seen this message from FreeBSD 5.x restore before.  It
had something to do with wildcard/glob matches while in interactive
mode (-i).  For the life of me, I can't remember how to trigger
it, and I can't seem to trigger it on my 6.x boxes (which used
to be 5.x).

I'll add that "out of memory" was quite an amusing message for
restore to print -- and the issue had nothing to do with memory
not being available, it was just something that would get printed
before erroring out on an operation that involved globbing or

I don't think your dump is useless.  I'd be curious to see how you're
doing the dumps, and how you're doing the restore session, though.

| Jeremy Chadwick                                 jdc at parodius.com |
| Parodius Networking                        http://www.parodius.com/ |
| UNIX Systems Administrator                   Mountain View, CA, USA |
| Making life hard for others since 1977.               PGP: 4BD6C0CB |

More information about the freebsd-stable mailing list