Machine hangs when loading snd_emu10k1

Mark Kane mark at
Sat Oct 14 00:32:44 UTC 2006

Hi everyone.

I rebooted my machine today and when it came back up and I tried to
load the snd_emu10k1 kernel module, the machine hung without returning
to the prompt. I tried waiting 5-10+ minutes and it was totally
irrecoverable. At that point, nothing had changed since the last
reboot so it was weird that it would happen all of a sudden.

Last week I did cvsup to RELENG_6 after 6.2 BETA 2 was out and built
world/kernel with the intent to update and use it, but I never got
around to finishing the process (I had not installed anything either,
so it was just sitting all built). So tonight when the hanging of
emu10k1 happened, I did the installkernel/installworld process as
normal thinking something might have been fixed between my previous
cvsup (September 21 I believe) and my current one from Oct 5.
Unfortunately there was no change in behavior -- it hung again and I
waited at least 10 minutes before hard rebooting.

I'm currently running:

FreeBSD amd64.localhost 6.2-PRERELEASE FreeBSD 6.2-PRERELEASE #15: Thu
Oct  5 17:52:05 CDT 2006
mixx941 at amd64.localhost:/usr/obj/usr/src/sys/AMD643000 amd64

With a Sound Blaster Augidy 2 Platinum:

none2 at pci2:8:0: class=0x040100 card=0x10021102 chip=0x00041102 rev=0x04
hdr=0x00 vendor   = 'Creative Labs'
    device   = 'SoundBlaster Audigy Audigy Audio Processor'
    class    = multimedia
    subclass = audio
none3 at pci2:8:1: class=0x098000 card=0x00601102 chip=0x70031102 rev=0x04
hdr=0x00 vendor   = 'Creative Labs'
    device   = 'EMU10K2 Audigy Gameport'
    class    = input device
fwohci0 at pci2:8:2:       class=0x0c0010 card=0x00101102 chip=0x40011102
rev=0x04 hdr=0x00 vendor   = 'Creative Labs'
    device   = 'EMU10K2 Audigy IEEE1394 Firewire Controller'
    class    = serial bus
    subclass = FireWire

Later on tonight I can try to cvsup to RELENG_6 and rebuild again to see
if it has been fixed already, but I need my CPU power for some encoding
at the moment. Also, I'd rather not have to do a third hard reboot with
an hour long fsck for seven hard drives, so I wanted to post here first
in case it's known already or if anyone has any suggestions before
doing it again.

Thanks in advance.


Internet Radio:
Party107 (Trance/Electronic) -
Rock 101.9 The Edge (Rock) -

MIXXnet IRC Network - (Nick: MIXX941)
-------------- next part --------------
A non-text attachment was scrubbed...
Name: dmesg.boot
Type: application/octet-stream
Size: 8517 bytes
Desc: not available
Url :

More information about the freebsd-stable mailing list