RELENG_6_1_p-10 Buildworld Freezes

Roger Cortesi rcortesi at MIT.EDU
Thu Oct 5 00:39:14 UTC 2006

Hello all,

I have spent the last week or so trouble shooting. I have been trying to 
upgrade by freebsd install to p10 (I started having problems when I 
tried upgrading to p9. I have been tracking RELENG_6_1.

FreeBSD is running on an older machine.  Its a Dell OPIPLEX GX1 355Mhz, 
64 Megs ram (yes the computer is really old and slow). I have never had 
problems rebuilding world before... it just takes 7+ hours.

Every time I run "make buildworld" the build freezes at the exact same 
point in compilation. The last line in the output is listed below.

cc -O2 -fno-strict-aliasing -pipe -DIN_GCC -DHAVE_CONFIG_H
-DHAVE_CONFIG_H -DTARGET_NAME=\"i386-undermydesk-freebsd\"
-DIN_GCC  -I/usr/obj/usr/src/tmp/legacy/usr/include
-c insn-attrtab.c

I have tried doing a "make cleanworld"... the buildworld still froze in 
the same place.
I have tried removing all the files in /usr/obj/... buildworld still 
froze in the same place.
I have tired removing all the files in /urs/src and doing a fresh cvsup 
of the source tree... the buildworld still froze in the same place.

Below are the non commented lines of my cvsup file.
*default base=/var/db
*default prefix=/usr
*default release=cvs tag=RELENG_6_1
*default delete use-rel-suffix

The contents of /etc/make.conf are:
# added by use.perl 2006-07-04 09:45:27

The output of my buildworld attempts have been logged using the script 

The suspicious part is that it seems to be the exact same point that the 
build freezes at.

At this point I'm out of ideas for trouble shooting this one.

Thanks for your time and thoughts.

More information about the freebsd-stable mailing list