ipw can not work in adhoc mode

=?GB2312?B?wO7I8L2t?= lithium7456 at gmail.com
Wed Mar 8 03:04:53 UTC 2006


See atttachment.
I have already submit this bug via "report a bug" in Nov last year, but
no reply, and the problem still exist in stable-6 now.
Any one who knows how to solve this problem ?
Thanks...
-------------- next part --------------
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">

<head><title>Problem Report kern/88917 : [ipw] ipw can not work in adhoc mode</title>
<meta http-equiv='content-type' content='text/html; charset=iso-8859-1' />
<meta name='robots' content='nofollow' />
    <link rel="stylesheet" media="screen"
    href="../layout/css/fixed.css" type="text/css"
    title="Normal Text" />
    <link rel="alternate stylesheet" media="screen"
    href="../layout/css/fixed_large.css" type="text/css"
    title="Large Text" />

<script type="text/javascript" src="../layout/js/styleswitcher.js">
</script>

</head>
<body>

    <div id="containerwrap">
      <div id="container">
        <span class="txtoffscreen"><a href="#content"
        title="Skip site navigation" accesskey="1">Skip site
        navigation</a> (1)</span><span class="txtoffscreen"><a
        href="#content" title="Skip section navigation"
        accesskey="2">Skip section navigation</a> (2)</span>

        <div id="headercontainer">
          <div id="header">
            <h2 class="blockhide">Header And Logo</h2>

            <div id="headerlogoleft">
              <a href=".." title="FreeBSD"><img
              src="../layout/images/logo.png" width="360"
              height="40" alt="FreeBSD" /></a>
            </div>

            <div id="headerlogoright">
              <h2 class="blockhide">Peripheral Links</h2>

              <div id="searchnav">
                <ul id="searchnavlist">
                  <li>Text Size: <a href="#"
                  onkeypress="return false;"
                  onclick="setActiveStyleSheet('Normal Text'); return false;"
                   title="Normal Text Size">Normal</a> / <a
                  href="#" onkeypress="return false;"
                  onclick="setActiveStyleSheet('Large Text'); return false;"
                   title="Large Text Size">Large</a></li>

                  <li><a href="../donations/"
                  title="Donate">Donate</a></li>

                  <li class="last-child"><a href="../mailto.html"
                  title="Contact">Contact</a></li>
                </ul>
              </div>

              <div id="search">
                <form
                action="http://www.FreeBSD.org/cgi/search.cgi"
                method="get">
                  <div>
                    <h2 class="blockhide"><label
                    for="words">Search</label></h2>
                    <input type="hidden" name="max"
                    value="25" /><input type="hidden" name="source"
                    value="www" /><input id="words" name="words"
                    type="text" size="20" maxlength="255"
                    onfocus="if( this.value==this.defaultValue ) this.value='';"
                     value="Search" />&nbsp;<input id="submit"
                    name="submit" type="submit" value="Search" />
                  </div>
                </form>
              </div>
            </div>
          </div>

          <h2 class="blockhide">Site Navigation</h2>

          <div id="topnav">
            <ul id="topnavlist">
              <li><a href="../" title="Home">Home</a></li>

              <li><a href="../about.html"
              title="About">About</a></li>

              <li><a href="../where.html" title="Get FreeBSD">Get
              FreeBSD</a></li>

              <li><a href="../docs.html"
              title="Documentation">Documentation</a></li>

              <li><a href="../community.html"
              title="Community">Community</a></li>

              <li><a href="../projects/index.html"
              title="Developers">Developers</a></li>

              <li><a href="../support.html"
              title="Support">Support</a></li>
            </ul>
          </div>
        </div>

	<div id="content">

<h1>Problem Report kern/88917 : [ipw] ipw can not work in adhoc mode</h1>
<p><strong>[ipw] ipw can not work in adhoc mode</strong></p>
<dl>

<dt><strong>Confidential</strong></dt><dd>
no</dd>
<dt><strong>Severity</strong></dt><dd>
serious</dd>
<dt><strong>Priority</strong></dt><dd>
low</dd>
<dt><strong>Responsible</strong></dt><dd>
<a href='mailto:freebsd-bugs at FreeBSD.org'>freebsd-bugs at FreeBSD.org</a></dd>
<dt><strong>State</strong></dt><dd>
open</dd>
<dt><strong>Class</strong></dt><dd>
sw-bug</dd>
<dt><strong>Submitter-Id</strong></dt><dd>
current-users</dd>
<dt><strong>Arrival-Date</strong></dt><dd>
Sun Nov 13 11:40:22 GMT 2005</dd>
<dt><strong>Last-Modified</strong></dt><dd>
Fri Jan 13 06:20:38 GMT 2006</dd>
<dt><strong>Originator</strong></dt><dd>
Li RUi jiang &lt;<a href='mailto:lithium7456 at sohu.com'>lithium7456 at sohu.com</a>&gt;</dd>
<dt><strong>Release</strong></dt><dd>
6.0</dd>
<dt><strong>Organization</strong></dt><dd>
</dd>
<dd><pre>
Fudan university,ShangHai,China
</pre></dd>
<dt><strong>Environment</strong></dt><dd>
</dd>
<dd><pre>
FreeBSD lith.3322.org 6.0-RELEASE FreeBSD 6.0-RELEASE #0: Fri Nov  4 04:19:50 CST 2005     root@:/usr/obj/usr/src/sys/CUSTOM_6  i386

</pre></dd>
<dt><strong>Description</strong></dt><dd>
</dd>
<dd><pre>
The machine running windows is set to adhoc mode. 
ssid is cat

On FreeBSD machine, I type:
----------------------------------
ipwcontrol -f /usr/local/share/ipw-firmware/ipw-i.fw
ifconfig ipw0 mediaopt adhoc
ifconfig ipw0 ssid cat
ifconfig ipw0 192.168.0.1 netmask 255.255.255.0
ifconfig ipw0 up
-------------------------------------
the led of wireless is on. 

then the windows machine says that it has detected a wireless network..
I choose join..and it said that the signal is very good.

But the windows machine can not receive any packet...and it was sending packet
continual. 

when I
---------------------
sysctl net.wlan.debug=-1
sysctl net.wlan.0.debug=-1
--------------------
the first tty said that:

"discard frame, not to bss"

continual
-------------------------------------
I am sure that my wireless card is good, and the windows machine's setting is right,
because the wireless worked when I run Windows.

My machine is 

IBM thinkpad T42
and my wireless card is 

ipw0: &lt;Intel(R) PRO/Wireless 2100 MiniPCI&gt; mem 0xc0210000-0xc0210fff irq 11 at device 2.0 on pci2
ipw0: Ethernet address:xxxxxxxxxx

</pre></dd>
<dt><strong>How-To-Repeat</strong></dt><dd>
</dd>
<dd><pre>
The machine running windows is set to adhoc mode. 
ssid is cat

On FreeBSD machine, I type:
----------------------------------
ipwcontrol -f /usr/local/share/ipw-firmware/ipw-i.fw
ifconfig ipw0 mediaopt adhoc
ifconfig ipw0 ssid cat
ifconfig ipw0 192.168.0.1 netmask 255.255.255.0
ifconfig ipw0 up
-------------------------------------
the led of wireless is on. 

then the windows machine says that it has detected a wireless network..
I choose join..and it said that the signal is very good.

But the windows machine can not receive any packet...and it was sending packet
continual. 

when I
---------------------
sysctl net.wlan.debug=-1
sysctl net.wlan.0.debug=-1
--------------------
the first tty said that:"discard frame, not to bss"continual

 
</pre></dd>
</dl><a href="mailto:bug-followup at FreeBSD.org,lithium%37%34%35%36 at sohu.com?subject=Re:%20kern/88917:%20%5Bipw%5D%20ipw%20can%20not%20work%20in%20adhoc%20mode">Submit Followup</a> | <a href="./query-pr.cgi?pr=88917&amp;f=raw">Raw PR</a> | <a href="./query-pr-summary.cgi?query">Find Another PR</a>

	</div>
        <div id="footer">
          <a href="../copyright/">Legal Notices</a> | &copy; 1995-2006
          The FreeBSD Project. All rights reserved.<br />
	  <address><a href='../mailto.html'>www at FreeBSD.org</a><br /></address>
        </div>
      </div>
    </div>
  </body>
</html>


More information about the freebsd-stable mailing list